Arctic Chat : Arctic Cat Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
OKAY I HAVE A 05 ZR 900 EFI WAS OUT IN THE FIELD TODAY WHITH A BUNCH OF OTHER SLEDS MY SLED IS STOCK EXCEPT FOR IT HAS THE 10.4 SECONDARY 85 GRM DOLTEN WEIGHTS DOLTON 54-40 HELUX AND IT HAS 192 STUDS THEY ARE 1.375 AND I RECINTLY INSTALLED THE SHIFT ASIST AND THE F1000 SECONDARY ORANGE SPRING THE SLED IS STAYING AROUND 7500-7600 RPM LEAVES LIKE A ROCKET BUT THE TOP END IS NOT THERE I WILL GIVE AN EXAMPLE I LINED UP WHITH A 06 F7 WAS OUT 2 LENGHTS ON HIM AND HE CAME AROUND ME BEFORE THE 660 FOOT MARK F7 IS TUNED TO GO AND HE CAN DRIVE O AND I AM ABOUT 225 LB WHITH GEAR ON ANY SUGESTIONS WOULD BE APREACHEATED THANKS
 

·
Premium Member
Joined
·
1,024 Posts
(reposted from the tech section.. just typed it up)
Steve

I finally had the chance to test out the Rktek DD secondary update kit (available now from OVS) on my 04' Zr900 EFI. I know that everyone has been messing with this setup but I think I've found the nearly perfect setup. This one works PERFECTLY. Shifts up and down just like it should. Has no binding (that's noticeable) at 100mph+. And this makes this sled shift just like the old clutching on 800's and 03' 900's. This shifts hard and fast. My setup is as follows.
1. 85 gram Dalton Weights on the primary and Purple 0646-155 spring
2. Secondary is the 10.4 cat clutch update with the Rktek/OVS Proprietary design. The secondary spring is a Red/White just like they recommended. The helix is a suprising 50/36 ramper that was used on the 04' stock (hard to believe).
3. Belt is the Cat 045 belt used on the 06's.
4. Stock gearing in the DD unit and stock drivers.

Now, here's where I did my own little mod. When I originally put the Rktek asm together I wasn't very happy with the spring preload that was necessary for the holes to line up on the outside cap-top asm. It seemed to be either too much preload or too little. I had some experience with my Formula Plus in 87 with this same type of problem and it was showing up here with either too fast of a shift out or too slow. At that time I decided I needed to just keep the spring preload light enough but not too much ahead of the stock positioning. This is not achieved with the stock drilled hole with the RKtek setup. So I redrilled a new hole for where I thought would be the best preload without having too much. On the SD you used a fish tension gauge to set it up. But after I messed with it awhile I noticed I could get a better setup by just pulling on it lightly and deciding for myself where to set it. I did this exact same procedure on this secondary and it turned out perfectly. So, there you have it. If you have a 04' 900 EFI with a 10.4, V-Force III reeds, ceramic pipe (stock), and slp can. You too can have it nice. That's my setup and I'm sticking with it. The rpms rev up from the bottom to a peak of about 7300- 7500 rpm (depending on snow conditions) and it just flies. Must better than the original setup and it must be working well. I put 800mi on it last week in the UP and it was GREAT !

YMMV of course, But it's the "Cats meow" for me ! lol

L8tr..
Steve
 

·
Registered
Joined
·
479 Posts
<div class='quotetop'>QUOTE (BIGBLOCKCHEVYCATMAN @ Jan 27 2007, 06:56 PM) <{POST_SNAPBACK}></div>
OKAY I HAVE A 05 ZR 900 EFI WAS OUT IN THE FIELD TODAY WHITH A BUNCH OF OTHER SLEDS MY SLED IS STOCK EXCEPT FOR IT HAS THE 10.4 SECONDARY 85 GRM DOLTEN WEIGHTS DOLTON 54-40 HELUX AND IT HAS 192 STUDS THEY ARE 1.375 AND I RECINTLY INSTALLED THE SHIFT ASIST AND THE F1000 SECONDARY ORANGE SPRING THE SLED IS STAYING AROUND 7500-7600 RPM LEAVES LIKE A ROCKET BUT THE TOP END IS NOT THERE I WILL GIVE AN EXAMPLE I LINED UP WHITH A 06 F7 WAS OUT 2 LENGHTS ON HIM AND HE CAME AROUND ME BEFORE THE 660 FOOT MARK F7 IS TUNED TO GO AND HE CAN DRIVE O AND I AM ABOUT 225 LB WHITH GEAR ON ANY SUGESTIONS WOULD BE APREACHEATED THANKS[/b]

Go back to the stock helix. Mark the primary clutch sheves w/ a magic Marker run a 1000 ft and check for full shift.
Did u use the 06 belt ? w/ the 10.4.

belt deflection?
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
SORY I MEANT TO SAY I USE A 50-40 HELUX BELT DEFLECTION SMACK ON AM USING THE 06 BELT HAD THE CLUTCH APART AND LOOKS LIKE IT IS NOT OPENING ALL THE WAY MAYBE THE SPRING IS TO STIFF FOR THIS APLICATION THANKS I WAS THINKING ABOUT THE RK/TEK SET UP ANY BODY ELSE USING IT
 

·
Registered
Joined
·
11 Posts
<div class='quotetop'>QUOTE (stevem5215 @ Jan 28 2007, 01:40 PM) <{POST_SNAPBACK}></div>
(reposted from the tech section.. just typed it up)
Steve

I finally had the chance to test out the Rktek DD secondary update kit (available now from OVS) on my 04' Zr900 EFI. I know that everyone has been messing with this setup but I think I've found the nearly perfect setup. This one works PERFECTLY. Shifts up and down just like it should. Has no binding (that's noticeable) at 100mph+. And this makes this sled shift just like the old clutching on 800's and 03' 900's. This shifts hard and fast. My setup is as follows.
1. 85 gram Dalton Weights on the primary and Purple 0646-155 spring
2. Secondary is the 10.4 cat clutch update with the Rktek/OVS Proprietary design. The secondary spring is a Red/White just like they recommended. The helix is a suprising 50/36 ramper that was used on the 04' stock (hard to believe).
3. Belt is the Cat 045 belt used on the 06's.
4. Stock gearing in the DD unit and stock drivers.

Now, here's where I did my own little mod. When I originally put the Rktek asm together I wasn't very happy with the spring preload that was necessary for the holes to line up on the outside cap-top asm. It seemed to be either too much preload or too little. I had some experience with my Formula Plus in 87 with this same type of problem and it was showing up here with either too fast of a shift out or too slow. At that time I decided I needed to just keep the spring preload light enough but not too much ahead of the stock positioning. This is not achieved with the stock drilled hole with the RKtek setup. So I redrilled a new hole for where I thought would be the best preload without having too much. On the SD you used a fish tension gauge to set it up. But after I messed with it awhile I noticed I could get a better setup by just pulling on it lightly and deciding for myself where to set it. I did this exact same procedure on this secondary and it turned out perfectly. So, there you have it. If you have a 04' 900 EFI with a 10.4, V-Force III reeds, ceramic pipe (stock), and slp can. You too can have it nice. That's my setup and I'm sticking with it. The rpms rev up from the bottom to a peak of about 7300- 7500 rpm (depending on snow conditions) and it just flies. Must better than the original setup and it must be working well. I put 800mi on it last week in the UP and it was GREAT !

YMMV of course, But it's the "Cats meow" for me ! lol

L8tr..
Steve[/b]
YES someone is using this setup
 
1 - 5 of 5 Posts
Top