Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2001 Z440 that back fires. I've cleaned the carbs so I don't think it is a carb issue. I also changed the plugs and that did not help. It gets worse the longer I run it. When I first start it it will cough or back fire once in a while but after a few miles the backfiring gets worse to the point of barely running. Anyone have any ideas?
 

· Registered
Joined
·
1,872 Posts
I emptied the tank replaced with good fuel and it still popped. Pulled carb apart and found no problems. I pulled it down and replaced crank seals and replaced all gaskets and completely sealed engine. No leaks. Reassembled and it was still popping through carb. I switched to a good coil and still popped. I have heard that stators can do this, so i tried swappin a new CDI and it still popped. Put in a new stator assy-problem solved. It gavfe me fits to find it because I figured the crank seal was the culprit because it was the pto cylinder doing it. Mag cylinder was not popping, and because these are single carb units, I figured the seal or something was sucking air. I hope this helps, it took me a week to figure it out. I am not sayin this is whats wrong with it, but it worked in my case. Good luck. :(
 

· Premium Member
Joined
·
6,570 Posts
On the new (refurbished) stator I just recently installed I had the ground eyelet break off and I was getting a lot of backfiring off the PTO side only for some reason (ZRT800). Repaired the ground and it's been great since.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top