Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
i have a 1999 z440 sno pro. i just put on a set of 2 inch handlebar risers about 2 weeks ago. then i noticed my handlebar warmers and thumb warmers don't work. today when i decide to go riding when i would turn them on it would shut off my rpm guage, headlight and taillight. so i went through the top wiring harness beside the steering post and i discover the line coming from the right handlebar warmer and connects the electric visor is dissconnected. so i reconnect it but when i start my sled i turn the warmers on and the lights are dimmed and hardly on and rpm guage is off. so i decided to keep it unpluged. So i unplug it because i think with them both on its drawing tomuch energy. Does anyone what my problem could be? Do you have any suggestions? PLEASE HELP ME!!!!!
 

·
Registered
Joined
·
15 Posts
<div class='quotetop'>QUOTE (z440snopro_23 @ Jan 18 2007, 07:06 PM) <{POST_SNAPBACK}></div>
i have a 1999 z440 sno pro. i just put on a set of 2 inch handlebar risers about 2 weeks ago. then i noticed my handlebar warmers and thumb warmers don't work. today when i decide to go riding when i would turn them on it would shut off my rpm guage, headlight and taillight. so i went through the top wiring harness beside the steering post and i discover the line coming from the right handlebar warmer and connects the electric visor is dissconnected. so i reconnect it but when i start my sled i turn the warmers on and the lights are dimmed and hardly on and rpm guage is off. so i decided to keep it unpluged. So i unplug it because i think with them both on its drawing tomuch energy. Does anyone what my problem could be? Do you have any suggestions? PLEASE HELP ME!!!!![/b]
With the warmers on and the sled off an idle, say 2500 rpms, do the lights brighten back up? If so this is normal all three of my sleds do it when its idling less then 1800 rpms or so.
 

·
Registered
Joined
·
89 Posts
Hey Z440, did you ever solve your hand warmer problem? I'm having a similar problem and it's got me stupefied! Did bypassing the safety switch make a difference, or was the problem elswhere?
Thanks
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top