Arctic Cat Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hey guys, I have an issue with my winch. When I hit the remote it doesn't click or anything. However when inhook battery charger directly to winch it starts trying to work. Any suggestions?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
29 Posts
Discussion Starter #2



Maybe you guys can recognize brand and common issues


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8,533 Posts
I would start with cleaning up all those connections on the contactor and the winch itself. I don't have a wireless remote winch but does remote need a battery?
 

·
Administrator
Joined
·
35,443 Posts
What do you mean the winch tries to work with jumpers ? That is a 2.5 CI warn
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
I would start with cleaning up all those connections on the contactor and the winch itself. I don't have a wireless remote winch but does remote need a battery?


I'll have to look at that when I get home. Picturing it in my head the switch is attached to the handle bars and wired.


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
35,443 Posts
It's in the winch if it's grinding. Those winches need to be taken apart, cleaned and greased fairly often if your in water a lot.

Not the same as yours just an example. I have lots of parts for those and they are really easy to rebuild. The pic I posted is one I rebuilt.

 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
It's in the winch if it's grinding. Those winches need to be taken apart, cleaned and greased fairly often if your in water a lot.

Not the same as yours just an example. I have lots of parts for those and they are really easy to rebuild. The pic I posted is one I rebuilt.



Cool! I need another little project. That ought to be fun. Thanks man! That's a lot of parts!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
Cool! I need another little project. That ought to be fun. Thanks man! That's a lot of parts!


Sent from my iPhone using Tapatalk


What kind of lubricant did you use inside the winch?


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
35,443 Posts
Moly 76 sparingly. Just enough to coat the gears otherwise it won't free wheel very easily. Check the drive shaft and tiny gear for wear. They get rounded off on the shoulders and won't engage properly.
If you take the motor apart you will need something like this to hold the brushes in place while you reassemble.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #11
Moly 76 sparingly. Just enough to coat the gears otherwise it won't free wheel very easily. Check the drive shaft and tiny gear for wear. They get rounded off on the shoulders and won't engage properly.
If you take the motor apart you will need something like this to hold the brushes in place while you reassemble.


Awesome thanks. I'll let you know how it goes.


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
About this Discussion
10 Replies
3 Participants
SddyTN
Arctic Cat Forum
Arctic Cat forum is a community to discuss Arctic Cat 400, 440, 500, 650, snowmobiles, sleds, ATV's and more. Join the fun!
Full Forum Listing
Top