Arctic Chat : Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
315 Posts
Discussion Starter #1
Hi, My 99 ZRT 600 has been loosing antifreeze all winter. I rigged up my leak down tester to put air in the antifreeze bottle. I put about 15 psi in the system and found a hose leaking and also leaking from little hole under water pump. :angry:

I assume its a weep hole if seal leaks. Can I fix the water pump with motor in the sled or does it have to come out? Do I need anything special to replace the seal?

I see they say replace the impeller when replacing the seal also.
 

·
Registered
Joined
·
3,340 Posts
You may be able to loosen the motor mounts and tip the motor back to remove the pump. You will more than likely need a impact driver to loosen the screws. Replace the impellar, washers, and mechanical seal.
 

·
Registered
Joined
·
315 Posts
Discussion Starter #3
I had the pump cover off yesterday because I thought the cover was leaking. I cleaned it up and put a little sealer on it and put it back on. After it sat to let sealer set up I put air in system again and it was still leaking so I looked under it with a mirror and saw antifreeze coming out the hole.

So the screws came out without to much problem. Just wondering why the impeller has to be replaced when replacing the seal?
 

·
Registered
Joined
·
3,340 Posts
A lot of times it wallows out where it goes on the shaft and will wobble and leak. When you take the mechanical seal out you will more tha likely have to use a small chisel to get it started coming out. Be carefull not to scar up the housing. A little does not hurt, but if you get deep it will not seal. Use a deep well socket to seat the new one and you should be good to go. A little sealant where the case halves meet is a good thing.
 

·
Registered
Joined
·
315 Posts
Discussion Starter #5
I had the cover off again. The impeller and shaft is worn bad. Can turn impeller back and forth a bunch on the shaft. So I guess it needs everything replaced.
 

·
Registered
Joined
·
79 Posts
I just did a total rebuild on my zrt 800 water pump yesterday. Besides the old mechanical being a little bit of a bugger to get off it was a breeze. I purchased the enitre rebuild kit from Snow800 on here. He had it to me in 2 days Mich.-PA and cheaper then you can buy anywhere else. Dont forget to replace the oil seal-mech seal-impeller seal and the little rubber washer on the impeller bolt.
 

·
Registered
Joined
·
3,340 Posts
most of the time the shaft does not wear. If it is pitted bad where the mechanical seal rides you may have to replae it, but I doubt it.
 

·
Registered
Joined
·
315 Posts
Discussion Starter #8
I threw it back together yesterday with some "right stuff" on the shaft where the impeller goes on and some "right stuff" on the bolt and rubber washer. I put 136 miles on it today and it didn't leak lol.Cat happy After winter is over I will fix it right.
 
1 - 8 of 8 Posts
Top