Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
703 Posts
Discussion Starter · #1 ·
Hey guys,

looking for some insite to tuning my RKTek kit. I know, a few of you are having good luck with this but not hearing much from the other guys.

>>>First ride, recomended flat lander set up. Red/white spring set in middle hole. Off the line had a bog that would clear itself with in about 100ft then would pick up and pull pretty hard.

Figured the spring was set a little soft and upon engagement the belt was getting yanked into the secondary... (no room for topend pull)

>>>so, second ride i tightened the spring one hole. This moved my bog farther into the the shift took longer to clear, but when it did again it would pull hard, but in, i dont know... 1500ft or so, could only pull 94mph at 7840rpm. I shift about 1/2" from the top of the primary and am still glazing at the top of the secondary. Also noticed that my rollers are running on the back of the helix.

Looking for some suggestions and tip for tuning this kit, what does what and where to start. Could i have the long dowel installed on the wrong roller? i thought i had it in the proper hole when i installed the kit? I will take some pics of my clutches when i get home tonight


***Also, may be my problem, but i all of a sudden i have started to use at least twice the oil i used to. 1/2 tank of fuel to one full reservoir of oil. <<< broken oil linkage or cable??? Havent playedwith the oil rod or anything.
 

·
Registered
Joined
·
89 Posts
I went for my first ride with the RKTek kit this past saturday. Unfortunately, I never got onto a lake or big field were i could really test the clutching. In the trails, the clutching seemed to be pretty good, no bogging and clutches were just slightly warm. I'm planning to head out with a buddy wednesday night to see if we can get it dialed in. Right now I'm in the center hole, red/white spring, 10.4 secondary in an 05 F7 EFI SP. I'll post what we come up with on thurs.
 

·
Registered
Joined
·
79 Posts
I ran mine this past saturday, but revs were to high(8150) with 73gram speedwerks weights

Backshift was excellant with a 48-38 progressive helix, and silver speedwerks spring in the middle hole on a 10.4 secondary.

Heat did not seem high on either clutch and no sign of using back of helix on backshift.

Going to increase primary weight next to bring rpms down.

Fast, check your oil pump and make sure its not stuck wide open! look at the pump rod and should be moving up and down with the movement of the throttle.
 
1 - 3 of 3 Posts
Top