Arctic Cat Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
I thought it was time to get my old sled rideable. I havent started it in well over a year. Filled it with gas and began the task of trying to start a triple in twenty degree weather. Wasnt as bad as I thought...only 30 pulls. Smoke a bit as usual on the trailer. Took her for a ride......It's amazing how the sled runs. Holy crap!! After around twenty minutes of blasting around, maybe 3 miles of riding seemed to be smoking more than usual. Like I said it runs absolutely perfect! Any ideas?? Thanks
 

·
Registered
Joined
·
504 Posts
Did you fog the motor before storing ? Or if stabe oil is added this can also cause excessive smoke .. i bought mine and it was smoking like U - know what .. and I called the guy I got it from and he said not 2 worry just get some fresh fuel in there .. he was right .. now prob now
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
Nope...didnt fog it. Maybe a stuck choke plunger. This is just a spare sled. Just seems to smoke excesively, even after its warm
 

·
Registered
Joined
·
282 Posts
Be Careful, Even though it seems to be running rich, That old gas (if you did not STABIL) Can mess up your jetting and lean a cylinder out.......
 

·
Registered
Joined
·
504 Posts
<div class='quotetop'>QUOTE (beaners @ Dec 22 2009, 10:09 AM) <{POST_SNAPBACK}></div>
Be Careful, Even though it seems to be running rich, That old gas (if you did not STABIL) Can mess up your jetting and lean a cylinder out.......[/b]

Sounds like you are going to be busy .. doing some checks wish I could help but tripples are a hole different beast 2 me.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #6
Cant be bad gas....Just added fresh fuel. I dont think I have a lean condition either. I have to further diagnose the oil injection system. Maybe the linkage or cable is stuck.
 

·
Premium Member
Joined
·
97 Posts
Check to make sure you don't have some kind of critter nest in your exhaust pipes ? Once your pipes got hot enough it might have ingited what ever is/might be in there
 

·
Registered
Joined
·
10,033 Posts
Usually they smoke alot on the first run of the year. Especially after sitting for an extended amount of time. Also will smoke alot if the weather was kinda on the warm side when your running it. If it continues just put some slack in the oil cable line so that the throttle moves approx. 1/8" before the oil pump starts to move. When the oil pumps go bad I have been told they go full rich. Check to see how much free play is in the oil line first.
 
1 - 9 of 9 Posts
Top