Arctic Chat : Arctic Cat Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1 (Edited)
So I tightened my track and now when i accelerate n as soon as the track starts moving it makes a bad grinding noise. Occationally before it would make a snap or pop noise when I would hit the throttle but after I tightened the track it is bad. seems like it might be ratcheting but my father said it might be something in the chain case. any thoughts? Also it only does it when i take off, once it gets going it goes away unless i hit akward bump then it does a little bit.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Also It does not do it when its on its side. If i softly squeeze the throttle when im standing on it wont then either. Its only when i give it a good bit of throttle it does it for like half a rotation of the track. It grinds a little and stops. It also has a good pop when it engages
 

·
Premium Member
Joined
·
4,337 Posts
Check the track drivers? possibly broke or stripped?
 

·
Registered
Joined
·
14 Posts
It sounds like the track guide/clips are hitting somewhere.. I suggest rechecking alignement and the tension of your track....plus the sprocket, chain case etc... but check the track first since it just happened after you adjusted it ;)
 

·
Registered
Joined
·
1,080 Posts
Make sure the track is centered/aligned. There is very little clearance in the tunnel for the track and if it is off center the slightest bit, the track will rub the tunnel and catch on some of the tunnel rivits.

Did you try loosening the track back up to see if the noise went away? Was the track ratcheting before you tightened it up? If not loosen it back up. I run the track really loose on mine and it has been fine. A loose track makes it free and fast.
 

·
Registered
Joined
·
1,756 Posts
X2 Green.. Cats like their tracks loose.... You have to make sure it's lined up bang on.. My tack turns 5 mph on a stand.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #10
My buddy works at my dealership and he texted me with an update. He said that my sprocket was shredded and the chain tensioner is completely shot. Should be done today or tomorrow! Ive been lost without my sled:boohoo:
 

·
Registered
Joined
·
14 Posts
My buddy works at my dealership and he texted me with an update. He said that my sprocket was shredded and the chain tensioner is completely shot. Should be done today or tomorrow! Ive been lost without my sled:boohoo:
I met a guy who had the same problem as you...mine is just looking like a new one. His track stretched up to the max within 500km, I dunno

Then the sprocket shredded etc... it seems that few people had that problem.. Good luck
 

·
Registered
Joined
·
2 Posts
So I tightened my track and now when i accelerate n as soon as the track starts moving it makes a bad grinding noise. Occationally before it would make a snap or pop noise when I would hit the throttle but after I tightened the track it is bad. seems like it might be ratcheting but my father said it might be something in the chain case. any thoughts? Also it only does it when i take off, once it gets going it goes away unless i hit akward bump then it does a little bit.


I heard same noises and found the bolts are snapping that are holding the helix to the secondary clutch
 
1 - 12 of 12 Posts
Top