Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
1,822 Posts
Discussion Starter · #1 ·
2200 + miles and this is the 1st teardown.......for an anoying oil lead at the base of the head.:wacko:

It was kinda slow in the shop this wk, so I decided to bring 'er in and have my mechanic pull the head off. I wasn't sure what else I might find, so I "pre-empted" and ordered almost a complete top end and was impressed with what we discovered when we got the pieces on the bench........

Virtually NO SIGNIFICANT WEAR on any of the major components!
CAMS - OK!
Piston - OK!
Chain tensioner's - Ok!
Valves - ok!
Cylinder - like new!

If anyone has ANY doubts about using AMSOIL.....this stuff WORKS!! (also a little OCD for maintenance helps)

My mechanic of 20+ yrs was stumped. He's NEVER seen a 650H1 is this good of shape with 2200 miles on it......Rockerdude





Oh I also discovered WHY the head was leaking. 2 Nuts that hold the head to the block on the right side.......MIA? No idea.I dunno

Just figured I'd share....
 

·
Administrator
Joined
·
40,662 Posts
Thanks!!! I like hearing a positive story
 

·
Premium Member
Joined
·
1,822 Posts
Discussion Starter · #3 ·
Well the Clap news - got'er back together and she runs perfectly!

The :Bangin: news.....

- broke my after market temperature sender lead for my gauge so it doesn't work....

- my GORILLA/PROMARK winch burnt up after making 4 passes to clean up snow that was collecting at my service shop door for the company BOBCAT to get.....DOUGH!! So I had to quickly install a NEW WARN winch I had in stock $$$... to push snow at home.....

- AND...my new gas gauge sender was "froze" at 1/2 a tank...so I ran outta gas after 10 min of plowing at home......

.....sigh........:huh::wacko::wacko:.
 
  • Like
Reactions: doorfx

·
Administrator
Joined
·
8,015 Posts
Startron helps those fuel level senders.
I add it to every tank of gas now.
Yup after 2 replacement gauges, $$$
the Startron is worth it's weight in oil (black gold, texas tea) lol
 

·
Administrator
Joined
·
40,662 Posts
X2 on the startron
 

·
Premium Member
Joined
·
1,822 Posts
Discussion Starter · #6 ·
trust me....I USE it. NOt sure what went wrong with the gauge. I bought it NEW in September. I'm thinking it maybe stuck....

regardless...I've got 6" of new snow to plow yet today, and I re-set the trip OD when I filled 'er Friday. SHe's good for 100 miles.....:lol:

I'll fix everything if/when this ridiculous winter ever ENDS.......
 
1 - 6 of 6 Posts
Top