Arctic Chat : Arctic Cat Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
412 Posts
Discussion Starter · #1 ·
Found out my tach max RPM doesn't reset after shutting down the sled – it always displays 7580 RPM. I know there's been posts on this before, but it's such a pain to search certain things/terms. Does anyone know if there's a way to fix or clear this, or does my gauge need to be replaced? – Roy
 

·
Registered
Joined
·
157 Posts
Hey Roy - I am having the same problem at 7640. I was told on another post to press the top button to get the Max RPM to display then press the bottom button to reset it. I haven't tired it yet. According to the owners manual it should reset when shut off but this doesn't work for me either. Let me know how you make out.
 

·
Registered
Joined
·
412 Posts
Discussion Starter · #3 ·
Mike, I should be able to check mine out later and report back. Hopefully with a little finaggling one way or another, we'll be able to reset the silly thing with out having to make a dealer run or replacing the whole dang gauge. – Roy
 

·
Registered
Joined
·
18 Posts
You guys are on the right track. Have it on the RPM setting and push and hold the top button and the bottom button. It should reset. May need to do it a couple times. (Pushing the botton button).
 

·
Registered
Joined
·
412 Posts
Discussion Starter · #5 ·
With RPM in digital mode, I held the top button (getting the "stuck" 7580) then simply pressed the bottom button (not holding it) and bammo... it reset just like that! Damn... wish ALL the little glitches were that easy to fix. Thanks guys! – Roy
 

·
Registered
Joined
·
412 Posts
Discussion Starter · #7 ·
Destruction manuals... LOL... gotta' love 'em! Try finding in there where it actually makes mention that the middle setting on the hand and thumb warmers is OFF, and not medium... LOL... took me a while (and some cold hands) to finally figure that one out! – Roy
 
1 - 7 of 7 Posts
Top