Arctic Chat : Arctic Cat Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter · #1 ·
My 2003 4Stroke has developed a starting problem just sitting in the trailer. When you turned the key to the accessory position everything works, but then as soon as you turn the key to start.....nothing, the lights do not dim and the starter does not turn. If you cross the wires at the starter it will turn over as normal. The sled is in the shop and they are leaning to a bad key switch or a wire ground someplace. The real bad news is if the starter needs to be replaced.....$900.00....if the solenoid is bad thats $200.00 plus labor....ouch!!!!

Also, check to see if your starter motor mounting bracket is cracked, this one is and this is the second one I have seen in the last six months.
 

·
Registered
Joined
·
81 Posts
I had a similar problem last year with my 2004 T660. When I shut the machine off the ignition switch fuse would blow. I could replace the fuse and it would be fine for a couple of rides and then blow again. I took it to my dealer in the fall and he cleaned the ground cable and replaced the ignition switch. I haven't been able to try it yet as we've had NO snow in WNY to ride.
 

·
Registered
Joined
·
266 Posts
Discussion Starter · #3 ·
They found the steel bracket that holds the starter motor in place had cracked and they felt this allowed the starter to move a little. This caused the little black wire on the back of the starter solenoid to come lose. It seems to be fine now. I will just have to watch and make sure that bracket does not break again.
 

·
Registered
Joined
·
1 Posts
Ignition Problem

My 2006 T660 Arctic Snowmobile when taken out of summer storage when attempted to start the machine started, ran for a short period of time then the starter engaged itself again and the key would not shut it off - had to disconnect the battery (kill switch would not shut it off either). Any suggestions anyone.
 
1 - 4 of 4 Posts
Top