Arctic Chat : Arctic Cat Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi folks, I'm still fighting with this 98 zr 600 efi. While i was checking over the electrical system, hoping against hope that it wasn't the stator that i just paid 200 bucks for that was causing the problem,I came across an odd situation. If I pull my kill lanyard off with the key in the on position nothing happens but if i turn the key off the motor won't shut off untill i pull the lanyard off. Any thoughts on this.
 

·
Premium Member
Joined
·
3,379 Posts
yep
either one may have carbon built up inside the switch
disconnect 1 and try it
then do the other switch
had a bad cdi on the thundercat not turn off sled with kill switch or key
 

·
Registered
Joined
·
6,673 Posts
Did the lanyard come with the sled? Could it be for a closed ignition system maybe?

As far as the $200 stators go, I've spoken to several hundred people that have purchased different variations of aftermarket stators and the general consensus is they last about 50 miles or 3 hours. I don't hear about the ones that actually last longer then that though. I imagine some must.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
The lanyard was on the sled when i picked it up so assume its the original. The stator was a used piece. never had a chance to run it. How would one tell if the lanyard is the proper one?
 

·
Registered
Joined
·
3,340 Posts
I would say they have the switch and tether wired wrong. I believe on a open ignition the hot wire y's to the switches as does the ground. On a closed ignition they are wired in loop as a open kills the motor on closed and on open it has to be grounded to kill it. You can test the switches with a ohm meter. with the key on it should read open and with tether plugged in, it should read open.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
I'll check those switches out. Would there be any chance that this has anything to do with my current running problem. Thanks
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
Ok so electrical is not my strong point. Could some one tell me what wire is supposed to go to what plug on the key switch and the tether. I have a brown wire, a purple wire, a black wire. and a black/white wire. The purple wire is coming up through the steering column and it is connected to the black wire which is connected to the tether, i think and the brown and the black/white connect to the to the key switch. Is that as clear as mud to you? Thanks for you help and your patience.
 

·
Registered
Joined
·
1 Posts
I have a 03 f5 and my headlights and taillight are barely on and my gauge on the dash doesn't come on at all why? any answers?
 
1 - 10 of 10 Posts
Top