Arctic Chat : Arctic Cat Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter · #1 ·
hey,
I have a firecat 700, 2003. I went snowmobiling today and my snowmobile started acting funny. It started to back fire so we changed the plugs and that didn't help it any. It sound like it is running of one cylinder.Alls i put on it so far is a sno stuff rumble pack can. I was wondering if you guys know or think what is wrong with it.
 

·
Registered
Joined
·
309 Posts
is there old gas in it ?
is it the right can ? try your stock again and see if it does it still.you can also unplug your stop button
i think it bypass your throttle switch if that is worn your sled will not run right . if your sled was running good before it"s got to be a simple fix. good luck
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #4 ·
There was some old gas in the tank but i filled it up before i went out. I was thinking that there was water in the gas so tomorrow im going to put some dry gas into it to see if it works any better. Also it started back fire at the last 10 minutes of the ride.
 

·
Registered
Joined
·
179 Posts
Every time my F7 would act the way yours does, it would only mean 2 things! I either had water in the gas and it started to ice up and it took out a piston! Or I cold seized another piston!

The same problems you are having is the same I had 8 times now!! And every time what I stated above is what the dealer told me I did! I have blown my engine up 8 times now! And its now in the shop for its last and final warrantied rebuild!

Hope your luck is better than mine!

Tom
 

·
Registered
Joined
·
102 Posts
Discussion Starter · #6 ·
Thanks for the help. I put dry gas into it today and let it sit then drove it but it still isn't working good so it is in our heated garage unthawing. I ckecked the compression in it and both sides have it so i haven't blown a piston.




P.S. This has happened to another sled i had. And i blew one piston one week and then the other one next week after that.
 

·
Premium Member
Joined
·
290 Posts
Is your sled EFI or Carb? Does it backfire constantly or only after a certain RPM?
 
1 - 7 of 7 Posts
Top