Arctic Chat : Arctic Cat Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
514 Posts
Discussion Starter · #1 ·
60 miles in to our ride this AM (-22 degrees... cold) I heard a "tangin" sound, metal to metal.....

Looked under the hood and saw nothing, and could not hear it.....

15 miles from the hotel the sound got worse, I lloked under the hood to see the recoil damn near off....... by the time we got it back it was completely off, laying in the belly pan.....

Any one else have the screw back out on theirs?

Just pissed me off..... had to cut the day short wirth 105 miles.

I have about 4300 miles on it.


Conditions were cold, but good.

 

·
Registered
Joined
·
370 Posts
Never saw one fall off before, but I had a buddies recoil grenade last weekend while on a ride. It wrecked the recoil, timing sensor, recoil cage, and the flywheel. Thank god the stator was ok. We got him going again after a day of finding parts and fixing and $300.

Where is the picture from? We were in St. Germain last weekend and it didn't look that nice.
 

·
Registered
Joined
·
514 Posts
Discussion Starter · #3 ·
That pic is 3 N on the way to Watersmeet from Lando.
 

·
Registered
Joined
·
113 Posts
My uncle had the same thing happen to his last weekend. He said he heard something right when we left the last time we stopped. Than when we got back to the hotel and parked behind the trailer he shut it off. Than he could not restart it. Than we got it started and it was dark you could see the sparks. The next day we looked and the recoil was off the motor. There is a lot of metal shavings in the bell pan.
 

·
Registered
Joined
·
547 Posts
The recoil on my F7 did the ring-a-ding last year and luckily caught it with one bolt still barely holding on. Put in new bolts with Loctite to fix 'er up.
 

·
Registered
Joined
·
182 Posts
Happend a lot on this board. Just buy some new bolts and loc-tite them in. You will not have a problem again.
 

·
Registered
Joined
·
781 Posts
I have almost 4,000 miles my F6 and only one bolt was holding my recoil!! Just one day my rope wouldn't turn the motor over so that really saved my damaged big time. I checked everything to make sure it was okay. None was damaged Wheeew! :bang:
 

·
Registered
Joined
·
514 Posts
Discussion Starter · #9 ·
Thanks for the responses. I don't remeber seeing this issue before.

Anyway, I had the Check Engine light flashing at me all day, so i dropped the sled off at the shop and asked them to make sure I did no other dameged to the recoil/flywheel area.

I will let you know if other damaged occured.
 

·
Registered
Joined
·
514 Posts
Discussion Starter · #12 ·
The report is....

One of the holes on the recoil system actually broke through, so i needed a whole new recoil assembly.

$200 installed.
 
1 - 12 of 12 Posts
Top