Arctic Cat Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter #1
Hoping someone can help me out and save some time. The clock does not keep accurate time, fuel level indicator will not read above 1/2 tank ( 4 bars I believe) the gauge is very hard to read compared to the same gauge on my X-Fire. I'm thinking I need a new gauge, anyone think otherwise? Also when I turn the handlebars all the way to the right the engine quits? Any thoughts before I start tearing apart? Sled is a 2008 F5 LXR

Thanks,
 

·
Registered
Joined
·
737 Posts
Make sure the connections are tight in the back of the gauge. Also for the engine quitting look at the wires that run down behind the steering post to make sure you don't have any pinched or frayed wires.

hope this helps Jeff
 

·
Registered
Joined
·
72 Posts
My wifes sled is a 2008 F570 - we had the same problem, there is a recall on the guage. It allows water to seep in, and moisture disrupts the accuracy of the reading. Have the guage replaced under factory recall.

As for the sled shutting down, sounds like a dead short somewhere in the electrical system. I agree with the previous post, make sure all cables and wires are free near the steering post, and check your side panels, sometimes the clips on the main wire harness rub on the panels and expose the wires. It happened on my 07 F6
Hope this helps.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #5
Thanks for the replies. I've got a new gauge on order. As Brian M. said the throttle cable didn't have enough slack in it when turning all the way to the right. Safety switch in the handlebar would shut the machine down because it sensed the throttle was stuck.

Thanks again,

Roy
 
1 - 5 of 5 Posts
Top