Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Just put a D&D can on my sons 95 EXT EFI MC and the thing sounds great but boggs at 50ish and doesnt pick up any power. It ran fine before so I'm guessing its the can. D&D said it should run the same as before the new can. Any other ideas?
Dan
 

·
Registered
Joined
·
317 Posts
he is right it shouldnt make a prob at all, all cans and pipes do is deliver the power at diff rpm's anyway, pipes may (may) give ya couple extra horses but not enough to justify the amount of the purchase(alot of people will argue that point). but changing the can shouldnt have done anything to the power, unless there may be a blockage do to packing debri or some such. Switch back and see if it still boggs, that should tell ya if its the can. Just some ideas.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
think it could be the clutch finally going out? I never replaced or serviced it in 2.5 years so I'll get that checked also. Going to do the can tomorrow.
Dan
 

·
Registered
Joined
·
317 Posts
Maybe, Might want to chk sec clutch, might be shifting to fast. Just an idea.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
well put stock can back on seemed to gain the power back past 50. After a few minutes of easy riding on a lake it hit 70 no problem. When I was having the problems a few days ago it was in deeper snow? Gonna take it out for a day trip and see what it does then try the D&D can again. Any other ideas or do I just have that sled that doesnt like the the aftermarket stuff?
 

·
Registered
Joined
·
714 Posts
I put a can on a 95 EXT 580 EFI once. No matter what I tried it would never run right. It would idle fine, but once you revved it up it broke up and ran horrible. I could put the stock can back on and it ran perfect.
 
1 - 6 of 6 Posts
Top