Arctic Chat : Arctic Cat Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Ok so I had my power valve run into my pistion and mess up the pistion and jug. I had just put a new power valve cable in befor It blew up.
I thought maybe I put the valve in backwards but when i took it apart it was the same as the other side(whitch has never been messed with).
So I think I must have missadjusted the valve but if somone has a better explination as to what happined your opions are welcome.

Also what is the proper way to adjust a power valve?

Thanks for the input.
 

·
Registered
Joined
·
32 Posts
I'm in the middle of adjusting my valves,,,,,,, I was under the impression that the valves could not touch the piston, that there was a stopper where the cable connects to the valve. I have heard that this can get worn which would allow the valve to travel lower (If I understod the post properly)???,,,,,,,,,,,,,,,
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Your right I dont know what I was thinking, I took another look at it and shure enough the power valve cant hit the pistion cust it rests on the bore in the jug.

So what the real cause of my problem was a broken pistion ring that took out the jug and pistion. I just adjusted the valves per the factory disk/manuel.

I took my sled out last saterday to Hurly Wisc. and put 170 miles on it, it ran great and kept up with my brother-in-laws edge 800 for the most part.
 

·
Registered
Joined
·
361 Posts
i have round valves and i can put them in wrong. theres 2 per side and if i witch the 2 around on one of the sides it will hit the piston.
 
1 - 4 of 4 Posts
Top