Arctic Chat : Arctic Cat Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Some buddies and I where out riding last night when all of a sudden mt sled boged once, then stopped running and glided to a stop. I thought it was just a stall, so I tried to restart, the rip cord would not come out... After checking the belt and removing it, tried to turn the primary clutch, it would go about 75% around then stop. Any ideas why this would be for a novice sledder....

Thanks a bunch for the feedback...
 

·
Registered
Joined
·
108 Posts
Hi,

I am definitely not the best source of info but from what you are describing, it sounds like a seized engine. How many miles are on it? Many things can cause an engine to seize. My guess is it probably needs to be torn down and rebuilt. Others on this site will give you better info than me but anytime the engine does not turn over normally, it is not a good sign. Good luck.
 

·
Registered
Joined
·
4 Posts
Odds are that you have a ring snagging in one of the transfer ports, thats why it wont roll all the way over. Basicly, your moter blew up. The bog was from a lack of compresion, it most likely melted the front side of the piston(exaust side)and that is where you have a piece of ring hooking on the exaust port. Be ready to spend a little money.
 

·
Registered
Joined
·
8 Posts
I HAD A 2002 M/C 600 EFI THAT LOCKED UP IT TURNED OUT TO BE THE FLY WHEEL MAGNET BROKE OFF PULL THE FLY WHEEL BEFORE YOU TAKE THE MOTOR OUT I WISH I DID

GOOD LUCK ZIM CAT
 
1 - 4 of 4 Posts
Top