Arctic Chat : Arctic Cat Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
Hey, I just picked up a digital camera and I took some pics of my new sled. It's a bran new '05 T660 Turbo Trail. Need some snow so I can break it in and try her out. Please post any input on this sled. Thanks!! :beer_cheers:
 

Attachments

·
Registered
Joined
·
183 Posts
Welcome to the dark side. did the dealer take care off the exaust recall so it doesn't melt your belly pan?
check where your vent tube is for the gas tank I had to reroute both my 04 and 05 so the gas wouldn't drip on my foot when the tank was full and the trails got messy. :beer_cheers:
 

·
Registered
Joined
·
114 Posts
I noticed on one of your pics that your secondary has the white plastic adjuster nut on it. I had some problems with it distorting, my AC dealer replaced it with an aluminum one, no charge. ( part #0648-440 Sheave Adjuster). I think I saw a post of yours on Snowmobile Fanatics, a few guys over there like to bash 4 strokes, reminds me of spoiled teenagers.
Enjoy the new ride :super_happy:
 

·
Registered
Joined
·
266 Posts
You should put a little extra heat foil under the hood right above the the turbo. This will protect the hood if the turbo gets a little to hot and you do not have enough air flow to protect the hood. It only cost pennies and if your hood does get some heat damage, Cat will not fix it, it's your cost!! Just put some on the left headlight bottom and on the hood and be sure to get the edges as well.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #6 ·
I haven't asked the dealer about the exhaust recall, what needed to be recalled in the exhaust that burnt the belly pan? Where exactly is the vent tube, should I just wait and ride it to see if it drips on my foot before taking the time to re-route it for no reason if it doesn't leak.

As for the white plastic adjuster nut, how do I know if it is distorting? and yeah I did post on Snowmobile Fanatics, haha they do like to bash four-strokes, but I don't really give sh*t. I like Arcticchat better anyway!
I'll pick some heat foil up this week and put it under the hood.
 

·
Registered
Joined
·
114 Posts
[attachment=60093:Burn.JPG] heres a pic of mine burnt. They replaced the pipe with one that didnt go up against the side panel. They replaced the side panel too.

The extra heat tape is a good idea, I did some on mine too.
The white adjuster, mine looked like it was pulling into the hole. Didnt look too bad till I started messing with it. If you need it, get the new aluminum one, much better.
 

Attachments

·
Registered
Joined
·
65 Posts
Discussion Starter · #8 ·
I just took some pics of my sleds exhaust. There is alot of heat foil where yours was burnt BearOnt. Look at the pics, do you think I'll be alright with it like that? I also have a pic of the heat foil that the dealer put on under the hood. Is there enough on the bottom of the lights and everywhere? Please let me know if you see any problem with anything, thanks!
 

Attachments

·
Registered
Joined
·
266 Posts
Just put some extra on and leave no black plastic of any kind showing and you should be good to go. I actually put a second layer on mine for I caught it just as the plastic was starting to melt.....under the hood....I have had no prolems so far with the exaust!!!!
 

·
Registered
Joined
·
114 Posts
The area by your exhaust looks good.
Below your left light there is a strip of plastic showing (between the foil on the light and the foil on the hood) I would cover that with foil also.
If you watch closely when you close your hood you will see that the heat shield over the turbo almost touches the hood there.
Mine was starting to melt there, almost missed it though, so I tapped er up good.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #11 ·
Yeah I'll have to get some heat foil for that, thanks for noticing that plastic by the left headlight!
 

·
Registered
Joined
·
53 Posts
I have an 05 Touring and had problem with left headlight housing melting. Added tape but the main culprit was the mfg. had the headlight aimed to low. After adj. was made, problem was over and AC had to flop for new housing. You would think they would R&D that before it hit the trails. 1300 miles on mine. Bought new last year. Good luck with yours,love mine!
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #13 ·
whats the MFG? yeah i had the sled out for the first ride yesterday and it was awesome!
 

·
Registered
Joined
·
1,043 Posts
does it have a boost gauge like the FST does in the instrument panel?? i wonder what they are getting for boost number with these 660's??
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #15 ·
no boost guage, I heard the boost stock is around 19 or 20. The turbo on these machines are amazing,
you feel the turbo spool up, then the sled just takes off, I've hadmine up to 105 so far, but takin it a bit easy cuz its bran new.
 
1 - 15 of 15 Posts
Top