Arctic Chat : Arctic Cat Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
1996 Pantera 580 EFI.

Excessive fuel comsumpsion. Approx. 2 miles per gallon.

Engine starts very well but runs rough from idle to full throttle. Runs fine at full throttle. 82 to 8500 RPM.

Engine compression is right on. New pistons approx. 100 miles ago. Was running fine until now.

Both clutches in good running order.

Good spark and new plugs.

No codes but analyser indicated incorrect coolant temp. Replaced coolant temp sensor.

Fuel Pump preasure at 36.2 as per A/C specs

TPS adjusted as per A/C specs.

Oil injection pump on specs.

Result....no differance.

I also own a 1996 ZR580 with identical equipment that runs perfectly. Swapped ECM , injectors, fuel rail, fuel regulator, injector sensor and intake air sensor from ZR to Pantera and Pantera indicated no improvement.

Getting ready to crush this one. Any help would be appreciated.

Tnx

Gil
 

·
Registered
Joined
·
316 Posts
it must be a bad time for panteras of all years. my 86 just had a major malfunction with the carbs. left me stranded half a mile away from the ranch. after 13 miles of rideing!!!!!!!!!!!!!! i feel your pain man.
 

·
Registered
Joined
·
122 Posts
Did the engine temp drop after coolant sensor swap? If the new engine job wasn't so good, you could have all the things you describe but since the engine is working hard, the computer reads that as demand, and would give you the indicated gas mileage. An engine working overtime will run hotter.

Change out the injector oil. Use all new stuff. See what happens and get back to us.
 

·
Registered
Joined
·
1,473 Posts
my neighbor had the same problem, I think it was something with the electronics.
 

·
Registered
Joined
·
10 Posts
Is there any raw gas in your exhaust? Try having carbs rebuilt. Similar problems with my 91 Cougar and needed new needle jets and good cleaning.
 

·
Premium Member
Joined
·
5,566 Posts
Buddies Dads 95 Pantera 580efi(1st year in the Pantera(ZRT I chassis)) was a pig on gas

86 SRV 540 took $15
96 ZRT 600 took $18
96 FIII 600 took $17
95 Pantera 580 efi took $23

All left with full tanks,and this is what we paid at the lodge we ended up at to refill full

That will always stick in my head at how much of a pig that 580 was on gas

I also liked that IO used less gas,even though I had to try to keep up,on the lakes it was a joke trying to keep up LOL
 

·
Registered
Joined
·
480 Posts
How do your plugs look? Maybe it's not the motor at all. If plugs indicate a proper fuel mix, it's probably running right. Try putting the sled up on a lift and check for rolling resistance. Maybe the track is too tight? Maybe a bearing or two is shot? The 580 won't be a gas mizer but 2mpg's is brutal. Good luck.
 
1 - 15 of 15 Posts
Top