Arctic Cat Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
My 2016 TBX has thrown this code three times in the last week. Every time it has been when driving at a pretty good clip (around 30+ mph) for a while while pulling a longer grade on logging roads. Not that I was also loaded each time. Unlike my 2010 I haven't had any electrical issues with this machine (other than blowing the fan fuse about once a year, which seems to be an Arctic Cat standard). My coolant is clean, but I am missing one of the heat shrouds on my exhaust pipe, I was wondering if that might be causing it in this warmer weather (it's been upper seventies to low eighties every time this happened).

The bike runs fine up to about 1/3 throttle when flashing the code, but misses if you try to give it more throttle than that. It isn't overheating, or at least the radiator is plumb full and it isn't puking coolant out the overflow hose.
 

·
Super Moderator
Joined
·
4,517 Posts
ECT code or engine coolant temperature

Full radiator doesn't do any good if the coolant isn't flowing and the radiator isn't dessipating the heat. Time to start checking the cooling system. First thing is to clean the radiator. They often get clogged up and not flow enough air.

Then it's on to fan, thermostat, pump........
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
I had my old one get clogged, this one doesn't look bad but I will try and clean it, fan appears to be working normally. I don't even know where the thermostat is in this thing.
 
1 - 3 of 3 Posts
Top