Arctic Chat : Arctic Cat Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
[attachment=63004:prowler3track.JPG]hi everyone
i am new here just got my 07 prowler with tracks and love it.
however i am having shifter problems and need some advice on how to get it to shift properly. i read how to fix the 06 problems but i think my 07 linkage is different. any help would be appreciated. i live in rural saskatchewan and a trip back to the dealer is a major undertaking.
thanks in advance
dingo
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi Kevin
Thanks for the welcome.
I hope someone responds to my post as this is very frustrating.
I think I have multiple problems going on.
The engine almost seems as if the reverse limiter is on all the time (because it is backfireing and not running smooth at all even in the forward gears) and it also seems to be idleing way too high. The only way I can get it to shift is turn it off then without the engine running I can shift thru all the different gears very easy and the different gears show up on the dash. I find neutral start it up, then quickly put it whatever gear I need before it gets a chance to rev up. If I do not do this it just grinds when I try to put it into gear if I am too slow to jam it in gear quickly. I tried to adjust the idle using the tach on the machine, then the next day it was idleing at around 3000 rpms and I never changed anything after I warmed it up good. When I parked it the day before it was ideling at around 1200 rpm. It is a fun ride when I finally get it in gear but for sure something is not right with it. I have about 40 miles on it and many screws and bolts have fallen out already so I am beginning to wonder if I got a bad machine.
Thanks
Dingo 1
 

·
Registered
Joined
·
723 Posts
My H1 idles high at first until the motor warms up. The electronic choke is kicking in to warm up the motor. Only does it when it gets real cold out. the crunching of grears sounds like a linkeage adjustment. I had to tweak mine as I was gettign that at times.
 

·
Registered
Joined
·
106 Posts
did you buy it used is the reason not taking it back to the dealer? i have copys of the factory service manual on cd, if you're interested let me know, only pay for the cd and the cost of mailing.
 

·
Premium Member
Joined
·
4,622 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
just a quick update
i have adjusted the idle and it now shifts much better.
i think i needed to get used to my machine and it to me :tongue_nana:
i ordered the cd from bill2099
after 50 miles and a little frustsration i am now a happy prowler owner.
it goes great in the snow with my tracks on.
i will be pulling the tracks and testing it out with tires.
thanks to those that offered help
dingo 1
 

·
Registered
Joined
·
10,000 Posts
<div class='quotetop'>QUOTE (dingo 1 @ Feb 7 2007, 04:09 PM) <{POST_SNAPBACK}></div>
[attachment=63004:prowler3track.JPG]hi everyone
i am new here just got my 07 prowler with tracks and love it.
however i am having shifter problems and need some advice on how to get it to shift properly. i read how to fix the 06 problems but i think my 07 linkage is different. any help would be appreciated. i live in rural saskatchewan and a trip back to the dealer is a major undertaking.
thanks in advance
dingo[/b]

Nice ride, Dingo!! :thumbsup:
 

·
Registered
Joined
·
445 Posts
damn that's sweet. Out of my price range.......but sweet.
 

·
Registered
Joined
·
723 Posts
Dingo Sorry I miised your post I have been off for a while I am glad you got it figured out. I had to re adjust the linkage on the shifter. After that I was all set. Good luck. Real nice looking machine you have there.
 
1 - 12 of 12 Posts
Top