Arctic Chat : Arctic Cat Forum banner

Need some help figuring out ignition problem

4691 Views 27 Replies 7 Participants Last post by  roym
So I just purchased an 07 Artic cat 700, I’m pretty knowledgeable about what does what but I’m stumped as to when I have a new battery. I go to turn key to on and I get zero response from fuel pump or tack cluster on handle bars. But when I turn key one more position I can now turn on lights but get nothing as far as ignition goes, I have checked all fuses relays are good. Just what else is there to check. I made sure wires were tight on starter as well.
1 - 13 of 28 Posts
I’m getting power to the key switch, tore all plastics off found I had a wire rubbed in half it was the only wire that was like that. But still didn’t fix it.
That will be next step will let you know out come
Still have same problem so still stumped
I don’t have a multi meter but I have a test light and all positions have power going to switch, I mean if the tart light saying it’s getting power pretty sure it’s working, and I’m probably going to get shade for assuming, it was just fine the other day and riding it so it wasn’t purchased with a like this
Ok guys I need to know what a bad switch low voltage would be testing with a multi meter. Also some other ideas to check and what to check if switch is good, I also have a switch on order. Battery is new fuse’s are good I went through entire wiring harness after I found broke wire. I didn’t encounter anymore wires broke. I fixed the one wire. I took apart switches on handle bars all wires were fine not corroded. Look me up on Facebook need a faster way to talk about this.Glenn Spangler
Also I have jumped silanoid it cranked over but wouldn’t start obviously, and yes kill switch was to it’s correct run position.
I’m getting power to everything but yet when I turn key to run position my cluster my fuel pump do absolutely nothing turn key one more position lights will come on
I put brand new fuses as well I am getting 10 volts to key switch not sure what I’m supposed to be getting. 12 volts is what I’m getting at every hot point
So after testing the switch. I do believe it’s the switch guys, so I’m hoping if I did my test right which I followed the service manual and it says to pull the key switch from the battery connector to where you just have Male adapter side of the key switch off. Then with multi meter check your pins. With key turned to on position. The meter being on ohm’s selection shouldn’t read more than 1 ohms if it does replace it. As I am going off of service manual details. I will post a screenshot of test points on switch and what points need to be checked in each position. Thank you to the guys that were giving input on what I should try, when my switch gets here I will let y’all know the outcome.
  • Like
Reactions: 2
Well after a wrong part came in and finally got the correct ignition switch it’s still a mystery as to what is wrong. New switch, new battery still not getting fuel pump to come on or pod cluster power? Next step
PROBLEM is solved check my other forum for what problem was it’s under 09 mud pro ignition problem
1 - 13 of 28 Posts