Arctic Chat : Arctic Cat Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I am installing a clutch kit on my 04 - F7. This is my first time installing Clutch Arms and I have a question. There are two o-rings on the bolt, when I put the nut on and tighten it the arm no longer swings freely. It seems like there is a little friction and the arm does not drop down freely. I didn't pay attention to what it did before I took the old arms off. Are they supposed to move freely or is there supposed to be a little frintion in the swing?

Please help.

Thank You.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
Thanks Ed, that's what I thougt. I put some red (max.) loctite on the bolt and tightened the nut enough so that the arms would still swing freely
 

·
Registered
Joined
·
795 Posts
The factory nuts are self locking, so they can just be snug and yet not back off.
I used blue loctite anyways, but it seems most used NO loctite, and yet they are okay.
 

·
Registered
Joined
·
130 Posts
When I put my ods kit on, my stock weights diddn't move freely at all. Made me wonder why they did that at the factory?? :sure_ok:
 

·
Registered
Joined
·
79 Posts
<div class='quotetop'>QUOTE (firecat823 @ Jan 14 2007, 03:52 PM) <{POST_SNAPBACK}></div>
When I put my ods kit on, my stock weights diddn't move freely at all. Made me wonder why they did that at the factory?? :sure_ok:[/b]
I found the same thing on my 05 F7. When I put the new weights in, I essentially ended up where they were from the factory (in terms of being snug, not totally free floating).
 

·
Registered
Joined
·
310 Posts
Just put set of Cutler's in xfire noticed it right away on first weight. I check one that was still in sled before removing and it did't swing freely. I just installed the new one to the feel of the stock ones. Hope this helps. Alos used blue loctite.
 
1 - 7 of 7 Posts
Top