Arctic Chat : Arctic Cat Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
795 Posts
Discussion Starter · #1 ·
I post in my weekend ride report to, but just a heads up.
Maybe mine was an isolated case, maybe not.
But the fuel line coming out of the tank was left loose by the factory causing mine to have a leak.
Four turns with a screwdriver tightened the clamp up sufficiently to stop the leak.
Glad it was not a fire I am posting about.
 

·
Registered
Joined
·
98 Posts
mine continues to leak /as well the one my cat dealer is riding is leaking.

i think it may require a pressure style clamp on it i have ordered one and will be trying it to see if this stops the leaking.
 

·
Registered
Joined
·
98 Posts
a tech Friend of mine thinks it may be that the clamp and perhaps the hose are not compatible with the fuel Pressures Being run .
 

·
Registered
Joined
·
76 Posts
<div class='quotetop'>QUOTE (medicnorth @ Jan 8 2007, 12:00 PM) <{POST_SNAPBACK}></div>
a tech Friend of mine thinks it may be that the clamp and perhaps the hose are not compatible with the fuel Pressures Being run .[/b]
sounds like your freind is one smart s.o.b.,

they should be using the clamps designed for higher preasure, not regular worm clamps, when they are overtightened the gear just cuts the hose, i'm not sure what preasures these things run , but maybe 40 to 50 psi , which is too much for the hose they are using , my buddies m7 the clamp is tight and the fuel appears to be wicking through the hose. i would defenitley change the clamp for starters
 

·
Registered
Joined
·
8 Posts
Mine was leaking at the bulkhead fitting on the tank too. It appeared to be weeping at the fitting/tank interface and not the hose. The hose was dry but there was fuel present on the face of the tank.

My dealer removed the bulkhead fitting and applied a little sealant. They also made sure the hose/clamp were tight. No problems since (100+ miles)
 

·
Registered
Joined
·
795 Posts
Discussion Starter · #8 ·
<div class='quotetop'>QUOTE (mwgasman @ Jan 8 2007, 09:53 AM) <{POST_SNAPBACK}></div>
Mine was leaking at the bulkhead fitting on the tank too. It appeared to be weeping at the fitting/tank interface and not the hose. The hose was dry but there was fuel present on the face of the tank.

My dealer removed the bulkhead fitting and applied a little sealant. They also made sure the hose/clamp were tight. No problems since (100+ miles)[/b]
Thanks I will undo my fitting and add thread sealer and retighten.


And what clamp style are you all recomending a switch to so i can buy them as well?
I have only the regular screw style in my parts bins in my shop.


Thanks everyone....this site does truly rock ! :beer_cheers:
 
1 - 8 of 8 Posts
Top