Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #1 ·
Hey guys, I have a question for you again.

It seems my ZR is lacking power. I currently have a D&D single pipe/can, D&D EFI chip, D&D clutch kit, and BM Monoblock head. All this is also pulling a 1.5" Camplast paddle track.

I finally had a chance to take it for a decent ride today, and ran into an issue. It runs great while on anything hardpacked, but it seemed when I hit powder, I ran out of power. With the D&D mods, it says I should be running around 8200 rpm's or so, but I could only pull around 7500-7800. After a bit of thinking, I replaced the D&D can with the stock can, and it ran like a raped ape. I hit powder, and she kept up great. Within about 10-15 miles, it was losing rmps yet again. It seems it can't pull anything over 8000 rpms when in powder. I just want to say that the snow was quite sticky, so maybe it was having problems pulling the paddle, but it shouldn't be that big of an issue.

So...Motor issue? Clutch issue? Other?

I had the clutch kit installed by my local mechanic who worked for a dealer for many years, so he knows what he's doing.

Any input would be greatly appreciated!
 

·
Registered
Joined
·
215 Posts
first check the belt for wear.
your track might be bogging you down and it sounds like its upshifting too quick in the powder. easy fix might be moving your secondary spring one hole to the right.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #3 ·
Thanks for the reply.

As I recall, the belt was brand new at the end of last season, so that shouldn't be a factor.

When it starts losing power, it almost sounds like a slight clicking or light ratching sound from the clutch area, that's kind of what leads me to believe it's clutching.

The machine only has 2,700 miles on it...
 
1 - 3 of 3 Posts
Top