Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 92 wildcat carburated, it idle's fine but when I give it trottle between 0mph and 40mph it sputters or sounds like it's cutting out, just wondering if anyone has any advice for me. Plugs are good I've got spark on both plugs my carbs have been cleaned. Just wondering what else I could check.

Any advice would be good advice. thanx
 

·
Registered
Joined
·
603 Posts
TSS, its pinned at the top of the ZR/ZL forum. 91 jag had the same problem. Thats my first guess.

(Throtle Safety Switch)

Edit...
Just looked and that forum is gone, now called z, zr, zrt, thunder cat.
 

·
Registered
Joined
·
199 Posts
Sure sounds like the safety switch- maybe try replacing the plastic bushings on the throttle pin first.
 

·
Premium Member
Joined
·
8,589 Posts
<div class='quotetop'>QUOTE (Big Gun @ Jan 25 2007, 07:11 PM) <{POST_SNAPBACK}></div>
Sure sounds like the safety switch- maybe try replacing the plastic bushings on the throttle pin first.[/b]

98aczl had the same problem and thats all it took was those two little inserts in the handle.
 

·
Registered
Joined
·
199 Posts
<div class='quotetop'>QUOTE (dadszr @ Jan 25 2007, 06:26 PM) <{POST_SNAPBACK}></div>
<div class='quotetop'>QUOTE (Big Gun @ Jan 25 2007, 07:11 PM) <{POST_SNAPBACK}>
Sure sounds like the safety switch- maybe try replacing the plastic bushings on the throttle pin first.[/b]

98aczl had the same problem and thats all it took was those two little inserts in the handle.
[/b][/quote]

You can often get them to sputter just by rocking the lever up and down- if it does, that's the first thing to replace.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Thanks guys for all the info, me and some of my buddy's went for a ride yesterday and before I went we bypassed the throttle safety switch and sure enough that was the problem. It runs great now. Again thanks for all the info, this is one of the best site's around.
 
1 - 6 of 6 Posts
Top