Arctic Chat : Arctic Cat Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
68 Posts
Hooked up my SII kit today and had no low beam (NB: had the rectifiers in the circuit, which I was told I needed). Hooked up the halogens again and all worked.

I did some research and, sure enough, as some had alluded to, the CTEC engine has a rectifier in its stock system, so, based on my extremely limited electrical knowledge (if I never dealt with anything electronic or electrical between now and my eventual send-off it would only be a good thing), I do NOT need the ones I was told to order with the LED kit. I will try to hook up the LEDs directly to the wire harness (ie. remove the SII rectifiers from the circuit) and see what happens. (P.S. Will be sending rectifiers back for a refund if they are not needed...)

Fingers crossed!
 

·
Registered
Joined
·
26 Posts
Hooked up my SII kit today and had no low beam (NB: had the rectifiers in the circuit, which I was told I needed). Hooked up the halogens again and all worked.

I did some research and, sure enough, as some had alluded to, the CTEC engine has a rectifier in its stock system, so, based on my extremely limited electrical knowledge (if I never dealt with anything electronic or electrical between now and my eventual send-off it would only be a good thing), I do NOT need the ones I was told to order with the LED kit. I will try to hook up the LEDs directly to the wire harness (ie. remove the SII rectifiers from the circuit) and see what happens. (P.S. Will be sending rectifiers back for a refund if they are not needed...)

Fingers crossed!
Did you get the Alpha LED kit from SII?

 

·
Registered
Joined
·
68 Posts
Did you get the Alpha LED kit from SII?

Yessir, that's exactly what I have (H4 kit, with the additional rectifiers, as per the site)
 

·
Registered
Joined
·
26 Posts
Yessir, that's exactly what I have (H4 kit, with the additional rectifiers, as per the site)
I have the NAOEVO kit (which has subsequently failed), and I only have a ballast driver and the bulb so my guess is it should work without the rectifier. Let us know if it works as I am be ordering that kit soon.
 

·
Registered
Joined
·
68 Posts
I have the NAOEVO kit (which has subsequently failed), and I only have a ballast driver and the bulb so my guess is it should work without the rectifier. Let us know if it works as I am be ordering that kit soon.
I removed the rectifiers and everything works (both beams). So, moral of the story, if your sled has a CTEC engine (6000 or 8000), you do NOT need to order the rectifiers (as there is already one in the sled; item 15 here: 2017 Arctic Cat ZR 6000 R XC GREEN (S2017ACDCCUSG) Front Bumper And Frame Assembly | Babbitts Arctic Cat Partshouse ). I am in the process of returning mine for a refund. I hope he updates his website (else others will go through the same thing).

P.S. They are VERY bright :)

P.P.S. I hope the refund goes smoothly....
 

·
Registered
Joined
·
26 Posts
I removed the rectifiers and everything works (both beams). So, moral of the story, if your sled has a CTEC engine (6000 or 8000), you do NOT need to order the rectifiers (as there is already one in the sled; item 15 here: 2017 Arctic Cat ZR 6000 R XC GREEN (S2017ACDCCUSG) Front Bumper And Frame Assembly | Babbitts Arctic Cat Partshouse ). I am in the process of returning mine for a refund. I hope he updates his website (else others will go through the same thing).

P.S. They are VERY bright :)

P.P.S. I hope the refund goes smoothly....
Thanks for the update. I will be ordering this this summer to replace my NAOEVO set that failed.
 
41 - 48 of 48 Posts
Top