Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
5,691 Posts
My stepfather owns a 02 Kawi 650 with over 7000km's on it. So far he hasn't had any issues with it other then regular maintence, adjusting the clucth, new belt this summer, shift linkage adjustments and thats been about it, nothing major or out of the ordinary. He has had 27" bearclaws on it since new, other then that all stock and he uses it for regular trail riding and hunting. About the biggest thing to look for is the belt delection, same setup as the cat V-twins.
There was recently a recall on the kawi's, I cant remember the specifics but I believe it was ball-joint related.
 

· Registered
Joined
·
5,691 Posts
I'm not sure if the 02 kawi 650's have the limp mode issue as there is no belt light on the first year of the praire's. Maybe there is and it just hasn't became an issue for the ol'man I dunno I did try to find out before posting but couldn't find the info. A good site with plenty of kawi info and tips is NYROC'S, you need to be a member to view the tips and I'm awaiting the verification email to become a member.
 

· Registered
Joined
·
5,691 Posts
<div class='quotetop'>QUOTE (acquad700 @ Jan 12 2007, 08:25 PM) <{POST_SNAPBACK}></div>
Thanks to all for the help and links to more info than this little brain can hold. Not worthy:
This thing sounds reliable enough for a short trip to a buds house up the road, pulling the mower, or for someone riding with me but, that's about it. This limp mode business is about the dumbest engineering marvel I've heard about in a while. To have a worn belt with slop, flip a switch and render the unit, for all intents and purposes, unusable isn't exactly the brightest idea but, the "just because" limp mode is, without a doubt, simply brilliant. Why they couldn't simply have a light and/or message on the display to signal service is required and save the shutdown for more catostrophic issues like high temp or low oil pressure is beyond me. I suppose it's best to mothball this thing for a couple of months and unload it in the spring. Thanks again for the info. It probably saved me either a long walk or waiting for someone to come pick me up and listening to the resulting harasment on the trip home. I'll stick with what I know....here kitty, kitty, kitty. :thumbsup:[/b]
I sure wouldn't let the limp mode problem deter you from enjoying the kawi and putting on some serious miles, if you do like it. I did some more checking (in the owners manual) and the 02's do have the "Drive Belt Failure Detection System" and that when the switch in the CVT cover is tripped the multifuction meter (???) and reverse indicator light flash. Also limits the engine to 3,600RPM and 2wd only. Now possibly they dont have the "false limp mode" problems like the first cats did or just my stepfather has been lucky, even my brother and cousin have 04 P700 and haven't ran into any belt problems.
Now dont take me wrong and trying to defend the kawi's here on a cat site but I would just wouldn't want a person to be afraid to drive something thinking it is going to leave them stranded everytime, its not a polaris now :lol: Like I mentioned in my first post it was about 6500 miles when my ol'man needed to replace his belt, after having no more adjustment (shims) left and this is him riding in high range 90% of the time too.
I wish they still made the praires now as I do really like them for my riding style, good of power and tourque, straight rear axle, low COG, not extremly heavy either. If it was a perfect world I would have one along side of my DVX to use most of the normal trail riding I do. Especially the LE team green ones :drool:
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top