Arctic Cat Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello,
I have ran across something on my ATV that has puzzled me along with some other mechanics I have asked. I was wondering if anyone has seen anything like this. I have a 2008 500cc 4x4. When this ATV is in high it acts like a rev limiter is kicking in when it is given 1/2 throttle or more. Even if you ease on it once it gets to around 20mph it does the same thing. When you move it to either Low or Reverse it does not impact the unit. You can put it in reverse and use the bypass and go way faster than you need to and it runs perfect. I have had one of my trusted friends that works on ATV's along with other thing and it has honestly baffled him as well. He spent a lot of time going thru it and brought it to another atv mechanic he was friends with and he could not figure it out. No voltage issue. No carb issues that we can tell. We have check the fuses. Has anyone ran across anything like this before?
 

·
Administrator
Joined
·
36,318 Posts
The diodes in your fuse block have been switched around. They need to all face the same direction as indicated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
You were exactly right. The small black diode on the right was turned the wrong way. We would have never noticed the arrow. When you take it out it shows the direction to put it. It was like this when I purchased it and we were concerned it was the brain (which is about $600). Thanks for the help.....
 

·
Administrator
Joined
·
36,318 Posts
No worries, happy trails.
 
1 - 4 of 4 Posts
Top