Arctic Chat : Arctic Cat Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
524 Posts
Discussion Starter · #1 ·
Ok, guys , my X-fire 7 is acting up....when I start the sled to warm it up idling is retarded, it is idling at 29-3100 rpm until it warms up and when it does, the rpm drops down to 22-2400 rpm, the only time rpm will drop below 22-2400 rmp is when it loads up and then it drops to the proper rpm of 1800-1900, when I start moving when the rpm drops to 18-1900 rpm it bogs heavily for the first 50ft. This has been going on for a few days now.

Why would my idle rpm be so retarded like this? I have a Boondocker but have yet to install it because I'm missing two black plactic connectors that were shipped out yesterday. Could it be that my engine is about to crap out on me? Should I look at the top end? What could it be? I'm clusless right now and I'm tired of banging my head against the wall.....HELP!!!!!

In decmeber I add Fitch Fuel Catalyst to my gas tank, and I'm wondering if this is causeing the high idle because it is stated that fitch cleans the fuel system and purifys your gas allowing you to drop at least one jet size. My mpg is the same as before, it is just idleing very high, is there a way I can turn my idle down until I get the connectors from boondocker?

Thanks

Jamesie
 

·
Registered
Joined
·
261 Posts
First check to see if the throttle bodies are stopping at the set screw, and verify that there is no ice or snow obstructing the proper function of the throttle movemnet.
 
1 - 2 of 2 Posts
Top