Arctic Chat : Arctic Cat Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
248 Posts
Discussion Starter · #1 ·
Hey guys, I dont know much about the part i found loose last night so i thought I'd ask about it. I stood on the sled and kinda rocked it side to side and it sounded like something was moving, which hasnt happend before, i found what the noise was and noticed that the sway bar is loose, i can grab the black piece in the pics and move the arm about a half inch side to side. Might not be a big deal but i dont want ignore it and have it turn into a bigger problem later. So any comments on how to tighten it or what-not would be greatly appreceated

:site:

Derk

[attachment=60264:IMG_0531.JPG][attachment=60265:IMG_0532.JPG]
 

Attachments

·
Registered
Joined
·
788 Posts
That is the sway bar end link. There is some play in it, although 1/2" sounds excessive. I would just recommend shimming it up with a couple wasters.
 

·
Registered
Joined
·
38 Posts
<div class='quotetop'>QUOTE (sledsearcher @ Jan 10 2007, 03:53 PM) <{POST_SNAPBACK}></div>
That is the sway bar end link. There is some play in it, although 1/2" sounds excessive. I would just recommend shimming it up with a couple wasters.[/b]
i have the same problem, you rock the sled from side to side and you can really hear it on the right side, i may have pinpointed the problem being a bad sway bar end link, can anyone confirm this?
 

·
Banned
Joined
·
159 Posts
After you pull the link and arm off, you'll see a plastic bushing in the sway bar tube on the sway bar... Slide it out and ck for wear.... I grease mine up alittle to help reduce some of that wear. I also put in the HD sway bar from ODS, just to see if it helps...Good luck ! :sledder:
 

·
Registered
Joined
·
332 Posts
what have you guys thought of the HD sway bar??
 
1 - 8 of 8 Posts
Top