Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I'm having trouble with hooking up my electric shield kit to my 1000. I was told by my dealer that there should be an open connnection to hook my connector to. Anyone have any idea where it is? I've checked the pod and the electrical connectors above the motor, can't seem to find it. Any help would be greatly appreciated.

Burner
 

·
Registered
Joined
·
68 Posts
I hooked up the accessory on my 2005 F5. The plug on the harness was located by removing the hood isolator ( That fabric looking cardboard under the hood held in place with some metal clips ) It was a two wire connector next to the back side of my instrument cluster.
 

·
Registered
Joined
·
32 Posts
I have New f-1000 and have Helmets with heat shields with the Co-Axle hook-Up. Some older artic Helmets have a unusual adapter but I believe even the arctic Helmets now have Co-Axle. I Purchased a quality accessory adapter from a Boat and Marine Shop. I got really lucky and found one with plug in leads that hook
up to the harness portion of a new electric shield kit. You can also splice if the connectors don't match. I now
simple plug in the accessory plug in Sled dash board. I do have a small exstention wire cord. The reason for this is many times I get off the machine and forget I am hooked up. The extenstion then just unplugs from Co-Axle and nothing Breaks. Also keep extra Cord and Converted AD Adapter in tool box along with small rachet and torx bit that fits front bolts only on dash for easy off and on of Hood!
 

·
Registered
Joined
·
249 Posts
The accessory plug is knee high just below the pull cord on your right inside the spar panel. It has a dead plug on it-just remove that. There's enough wire in your helmet plug in to bring over to the left side spar panel. I drilled a hole in the spar panel and put a bushing in. It works perfect!
 
1 - 6 of 6 Posts
Top