Arctic Chat : Arctic Cat Forum banner
1 - 9 of 9 Posts

· Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Can anyone help me i have a clicking sound ,it seems to be under my left foot.
I've flip the machine to it side and check out the jack shaft it seems tight.
Check out primary & secondary clutch there fine seeing that there's only about 1000 mile on them.
The only other thing that i think might be wrong it;s the bearing in the crank case.
If anyone else had this problem or might help me diagnose this prob,plz reply.
 

· Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
<div class='quotetop'>QUOTE (Wayne from Pontypool @ Feb 18 2007, 05:59 PM) <{POST_SNAPBACK}></div>
Does the speedo still work? Does it only click when the sled moves? click faster the faster you go?
At this point thinking drive shaft bearing or maybe just ice build up in the tunnel[/b]
yes the noise only comes as the machine is in motion, it's most noticeable when
I'm slowing down. mine you i can't ear it at high speed seeing that the 3 pipes are to loud.
 

· Registered
Joined
·
90 Posts
I had the same type of clicking sound on my 98 ZRT this weekend. I found one of my studs had pulled and ripped a little 1x1 section of the track. The resulting little flap collected ice and was clicking as it went around. I also noticed my belt was chewed up.
 

· Registered
Joined
·
383 Posts
Clicking can be related to impending primary clutch failure. When was the last time you rebushed your weights on your primary?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top