Arctic Cat Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2007 z1 jaguar 1100. Not turbo...
Stud put hole in front exchanger, had it welded but leaks from behind the exchanger. He said he can’t do anything about it. Everything is perfect on this sled and really hard to understand that this is now junk...or is it? Any ideas??
 

·
Registered
Joined
·
10,174 Posts
Ooooh!! That sounds like a motor pull in order to get good access and do a proper repair.
 

·
Registered
Joined
·
1,139 Posts
It sucks, big time, but you'll have to pull the exchanger, assuming the welder knows what he's talking about. Either weld it or replace it. It won't be fun. That's one of the reasons I don't run studs.
 

·
Registered
Joined
·
10,174 Posts
It sucks, big time, but you'll have to pull the exchanger, assuming the welder knows what he's talking about. Either weld it or replace it. It won't be fun. That's one of the reasons I don't run studs.
Correct me if I'm wrong, but are these not welded in place and a complete chassis needs to be changed if non-repairable?
 

·
Registered
Joined
·
1,139 Posts
Yikes!! You are right, I had Procross on my mind. He is screwed. The stud went through both layers of the exchanger? I would find another welding expert for a second opinion, before pulling the plug on it.
 

·
Registered
Joined
·
10,174 Posts
Yikes!! You are right, I had Procross on my mind. He is screwed. The stud went through both layers of the exchanger? I would find another welding expert for a second opinion, before pulling the plug on it.
Screwed for riding but without pulling the engine you can’t make a proper assessment on damage and possible repair.
 
1 - 6 of 6 Posts
Top