Arctic Chat : Arctic Cat Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
3,532 Posts
<div class='quotetop'>QUOTE (BRB @ Feb 10 2007, 09:43 PM) <{POST_SNAPBACK}></div>
<div class='quotetop'>QUOTE (ster @ Feb 10 2007, 10:12 AM) <{POST_SNAPBACK}>
What updates are the early builds getting??[/b]
Something to do with the computer I was told. The dealer said it acts like it instantly floods when trying to start it.
[/b][/quote]

You may be right, but I'm thinking it was something else. My dealer said he has to take the engine out for the update, which leads me to think it's not computer related. I'll have to ask him the next time we speak.
 

· Registered
Joined
·
3,532 Posts
<div class='quotetop'>QUOTE (Steve Cook @ Feb 12 2007, 04:17 PM) <{POST_SNAPBACK}></div>
I think that I would be looking for a different dealer!!! --- even if you have to drive aways!!!!

There are "NO" engine updates for the Jag (as of yet), I have a Jag Z1 and my dealer and I have a very close relationship.
Your dealer sounds like 1. he don't wanna sell a sled and 2. He's full of crap!!!

It is true that if you let the engine idle for short periods, it "will" foul the plugs! I know, it happened to me and the repair bill was $200.00.

Shop around, at $11k for a sled, I would look for the best dealer 1st. then the best deal!!! (I did)!!!

Good luck..
Steve...[/b]
Steve, maybe your VIN doesn't require an update. There is one out there on the early Jags though, not sure if it's an "engine" update, I just know my dealer said he has to pull the engine to do the update...maybe it's chassis related. I feel the same about my dealer as yours, he wouldn't steer me wrong. He has no reason to make something like this up. I'll email him and get back to this.
 

· Registered
Joined
·
3,532 Posts
<div class='quotetop'>QUOTE (TallCool1 @ Feb 12 2007, 08:06 PM) <{POST_SNAPBACK}></div>
<div class='quotetop'>QUOTE (Steve Cook @ Feb 12 2007, 04:17 PM) <{POST_SNAPBACK}>
I think that I would be looking for a different dealer!!! --- even if you have to drive aways!!!!

There are "NO" engine updates for the Jag (as of yet), I have a Jag Z1 and my dealer and I have a very close relationship.
Your dealer sounds like 1. he don't wanna sell a sled and 2. He's full of crap!!!

It is true that if you let the engine idle for short periods, it "will" foul the plugs! I know, it happened to me and the repair bill was $200.00.

Shop around, at $11k for a sled, I would look for the best dealer 1st. then the best deal!!! (I did)!!!

Good luck..
Steve...[/b]
Steve, maybe your VIN doesn't require an update. There is one out there on the early Jags though, not sure if it's an "engine" update, I just know my dealer said he has to pull the engine to do the update...maybe it's chassis related. I feel the same about my dealer as yours, he wouldn't steer me wrong. He has no reason to make something like this up. I'll email him and get back to this.
[/b][/quote]

Alright, they didn't have to pull the motor afterall, but still a few updates on the E.B.'s.:

"Hey Jim, no motor pulling LOL, thought we were going to, but after
looking at a few of the update sheets we dont have to. There are a couple of
them, 1 is a steering colummn update, 1 is a gas tank cap, a clutch guard, a
sensor, then we had to take clutch off and gear case and send back to arctic cat
to get them upgraded. These are on the early build Jag Z1 models only. Snowing
to beat heck out right now but also lots of wind. Snow out in the country where
I lived, I broke a few drifts today that were up past my front bumper on my
truck and it even has the bigger tires on it. It was fun for awhile till I got
the truck sideways LOL. Have a good day."

If he still has this come fall, I'm thinking I can make a pretty good deal on it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top