Arctic Chat : Arctic Cat Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 94 EXT that seems to only be running on one cylinder. It fires when you pull it, but only runs for a split second and dies. When I pull the plugs and check them, the right plug is soaked and the left is dry. Spark seems fine on both cylinders though.

Another thing I found sort of weird was when I pull the sled over with the plugs off, I literally get fuel gushing out of the right cylinder but none comes out of the left cylinder. Does that mean one cylinder is getting too much fuel? I pulled the pipe off as well and found a puddle of fuel in the Y-Pipe. Any ideas? Am I going about this the wrong way?
 

·
Registered
Joined
·
618 Posts
Not that familiar with EFI if it was carb it would be easy. maybe stuck injector. Im sure someone will chime in who knows. If you had gas in the Y-pipe chances are theres some in the expansion chamber make sure it's dry before you try starting it once you get your problem fixed.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Not that familiar with EFI if it was carb it would be easy. maybe stuck injector. Im sure someone will chime in who knows. If you had gas in the Y-pipe chances are theres some in the expansion chamber make sure it's dry before you try starting it once you get your problem fixed.
I unbolted the fuel rail and pulled the sled over and both injectors seem to be shooting about the same amount of fuel. It's weird. I dunno I'm at a loss. Sucks because I've missed the better part of the season here with it broken. Wish I could afford something newer
 

·
Premium Member
Joined
·
4,337 Posts
Remove plugs, turn key off and kill switch in off position and pull till no more fuel coming out of the spark plug holes. Replace plugs with new. Take spark plug caps off and trim about 1/2" off the end and put caps back on.

Hope this helps
 
1 - 7 of 7 Posts
Top