Arctic Chat : Arctic Cat Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter · #1 ·
This damn sled is starting to get on my nerves! The last two times I went to start it since my wreck the motor was flooded. Went to go out today and the motor was hydro locked with fuel. Pulled pipes and plugs, shut off fuel and pulled for about a half hour and its still spewing fuel. My carbs are clean as I've been riding it. This just started after my wreck. Needles are fine. I've noticed anytime I get back from riding that there's fuel in the vent line and its bubbling. Any ideas?

Sent from my SAMSUNG-SGH-I777 using Tapatalk 2
 

·
Registered
Joined
·
142 Posts
I would say either your needle valves aren't fine, or the floats are sunk or sticking. I'm not sure how common that is. just went through the same problem on my dads 440 after a weekend of fighting it on Mille lacs. Fishing was good, but he had to shut off the fuel everytime we stopped otherwise it would flood the engine. I can say I told him so because I told him to replace the needle valves after it dumped a ton of gas through the vent line on my garage floor. Not a happy wife! :screwy:

Sent from my XT907 using Tapatalk 2
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #5 ·
I'm thinking something is up with my fuel tank or pump. I do this for a living and its not the carbs. This didn't start till after I totalled the sled. I can't think of what would've been effected from the wreck.
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #6 ·
Ok the pump is creating a syphon on the tank. Odd. I'm just gonna light it on fire and file an insurance claim! I'm sick of this machine. Only got limited ride time cause of snow conditions and yet I'm dealing with stupid **** all the time.
 
1 - 12 of 12 Posts
Top