Arctic Chat : Arctic Cat Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
well im running out of ways to turn and patience with this sled it is a 2008 f8 efi sno pro. it has like 2600 miles on it. i have had this poblem since i got it in the begining of the year. it will run fine at high rpms like 6500 plus rpms it runs fine, but any thing under that it starts spitting and sputtering and backfiring like crazy. :Bangin: the only thing i have noticed is that the needle gauge starts bouncing aroundlike pegging out to zero and stuff while the sled is running like crap, ive serched for wiring issues and have found nothing i dont get it
 

·
Registered
Joined
·
16 Posts
Discussion Starter #2
i forgot to ad i had one code come up ecu 21 wich is nock sensor failure, i stoped shut the sled off and it didnt come back on
 

·
Registered
Joined
·
4,198 Posts
Have you........

-confirmed cable slack is adjusted to spec?
-if ok, disconnect throttle safety switch and retest?
-confirm throttle body boots are not split?


Needle gauge bounces..............what gauge?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
ok i will try that and my tach gauge when it is in the anolog setting bounces around like somthing is shorting out when it is breaking up and running like crap
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
so i talked to the tech at my local arctic cat dealer and he says that if it threw the knock sensor that it is probly throwing the whole sled off and making it run extremly rich and i checked the ground it is all good but the one kind above the brake disk was a littled crudded up
 

·
Registered
Joined
·
4,198 Posts
Did you value check all sensors plus the throttle stuff I posted?
Same for did you confirm exh valves and cables are clean and properly adjusted?
If it was running poorly, chances are that is what set the deto light off.
If it's been stored without using Stabil or SeaFoam, cheap insurance to pull the injectors out and soak overnight in SeaFoam.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9
i downloaded the manual it was a big help! i did the stator test and it was all good as well as the injectors, i couldnt find anything on how to test the knock sensor though, i took some duck tape and double sealed the air box where it fits together by the oil tank, is it ok to spray some carb/choke cleaner on the intake boots to check them? or will that do damage? they look fine but just a double check
 
1 - 10 of 10 Posts
Top