Arctic Chat : Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
i have a f6 2008 that keeps blowing bulbs i put on a new regulator and cleaned and checked all grounds still blowing bulbsI dunno
 

·
Registered
Joined
·
320 Posts
cdi would be a box that electronically tell the coils to fire...ignition/spark timming more less...
 

·
Registered
Joined
·
4,198 Posts
With it running, did you check what the actual voltage is?
CCU is on the rt side of your sled close to the alum spar panel, is that what you replaced? Pretty sure they cost upwards of $300, sound familiar?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
With it running, did you check what the actual voltage is?
CCU is on the rt side of your sled close to the alum spar panel, is that what you replaced? Pretty sure they cost upwards of $300, sound familiar?
i dont know what the voltage is but i know it was a lot to blow bulbs like crazy the part i replaced was silver with 4 wires coming out of it any other ideas what could cause it:huh:
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
i checked the voltage it starts at 14.5 and increases during acceleration but i know it was a lot to blow bulbs like crazy the part i replaced was silver with 4 wires coming out of it i checked all grounds tested them and cleaned them
 

·
Registered
Joined
·
4,198 Posts
Either the CCU is not regulating OR you have an issue right at the stator itself.
STop running before you damage other electrical components like the ECU.
Do you have a part number on what you replaced?
 
1 - 8 of 8 Posts
Top