Arctic Chat : Arctic Cat Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
163 Posts
Discussion Starter · #1 ·
My mud pro is showing p0116 and a over temp icon. What part is bad or what is going on. And it's slowly leaking behind the thermostat only when it get s hot. Help
 

·
Registered
Joined
·
435 Posts
Change the gasket then. Leaks are not good........ You probably lost most of your antifreeze and thats the reason its showing HOT.
 

·
Registered
Joined
·
1,437 Posts
sounds like it leaked enough to cause an air pocket
you may want to run it with the cap off until the thermostat cycles..then top it off..
id say fix the leak and your code will go away..
 

·
Registered
Joined
·
5 Posts
Hey I just had the same Code P0116 appear along with the over temp and check engine icon. So my rad was plugged so i got that cleaned up. I can't find any leaks in the coolant system but it appears to be low. I live 3 1/2 hours from any dealer and i was wondering what kind of coolant i should run in my machine that is compatible with the dealerships?
 

·
Registered
Joined
·
2,627 Posts
I run Toyotas Long Life red coolant. It's great stuff. If you have a Toyota or Honda dealer close by either coolant would be a great upgrade to the AC antifreeze.

I run the Toyota Red stuff in all of my vehicles. Not sure if other people have used regular green coolant or long life so I cant comment if those are acceptable replacement for the AC coolant. Just don't use DexCool. It's by far the worst crap there is. GL.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top