Arctic Chat : Arctic Cat Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 08 trv 500 when u turn the key the dash lights up red but no info displayed and if I turn the key to the lights position dash light gossip out and won't start any idea what the problem is
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #2 ·
So I pulled the ignition switch apart there was corrosion in side cleaned it up know the red back light stays on in both possessions but still no guages nothing just a blank red screen any ideas?
 

·
Administrator
Joined
·
40,660 Posts
Start checking connections and di/electric grease every one.check the one at the back of the pod. Try disconnecting battery overnight
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Ya I checked the pod pulled it apart cleaned it up yesterday today it started to come on when I shut it off then it went blank so I rocked the starter switch back and forth and it started working cleaned up the switch worked fine know it's sat for a hour no guages again
 

·
Administrator
Joined
·
40,660 Posts
New switch or a broken wire
 

·
Registered
Joined
·
17 Posts
I had this happen one time just after I bought my machine. I found that I had to undo the battery connections, hold the positive and negative battery cables together and then reconnect the cables and all was good. I have no explanation for this I think I actually found that repair fix on this site and it worked.

Mine happened after I had ran the battery way down winching with the lights on......
 

·
Registered
Joined
·
113 Posts
Mine does the same thing if I run the battery down to low, throw it on the charger for a while and everything works fine again.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top