Arctic Chat : Arctic Cat Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter · #1 ·
I have a kit for my 03 f7 from D&D for the stock or single pipe I have the earlier version of the light pipe I put the spring in the middle hole it works ok but it my buddies stock 03 f7 will stay beside me or a little bit behind me my rpms are around 7800 and I can only get to about 95 mph Then I adjusted the spring looser hoping I would acclerate more but now I over rev at 8100 or moreWhat should I do to make my sled acclerate faster or are my expectations set to high from this kit
 

·
Premium Member
Joined
·
1,711 Posts
As stated on another site, check the helix if it is the the DDAST it plain sucks. Just going from that helix back to stock 53/51 picked up a better hole shot and top end mph from 95 to 101, then switched to another angle and hole shot the same top end to 103-104 on GPS.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #5 ·
I wish some one from D&D would read this and help me out I have been calling you guys and no one returns my calls now I have put a brand new belt on spring in the middle hole my sled will hit 8600 rpms really quick the belt deflection is tight the track will move slightly when on a stand I think I might just throw this in the garbage and go back to stock
 

·
Premium Member
Joined
·
1,711 Posts
Since you have DDA (helix angle is 56/52) you have the stock pipe kit from D&D. The D&D kit for the 03's for the D&D lite pipe the helix would be DDAST. Your belt should be the 0627-020 or its equal. Depending on what secondary spring you have D&D would have sent there Grey (the sheet from my kit I got back in July 03, shows grey spring to go in 4th hole, going from left to right). If the stock red with white stripe is being used that one would most likely be in the middle hole. Send a PM to hallnracing, Glen will ya out. To help him with what needs to be done, include the weights of the weights, the primary spring color, the helix number, the secondary spring color and the belt you are using. Will say this if you using anything other than the 020 belt, you rpms will be way off, almost sounds like you have the 035 belt as that belt will put the rpms of an 03 up that high, 03's only like the AC 020 belt.
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #10 ·
I finally got help from D&D I have the wrong springs I needed a green 2ndary spring and a yellow primary spring hopefully this works or I will be giving Dan a call for his kit
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #13 ·
go with what he said that is the truth I had a ODS kit in my 03 F5 and it ripped right out of the box no messing around I wish I bought one for my F7 instead of D&D MY butt hurts from me kicking it every time I ride my sled
 

·
Registered
Joined
·
122 Posts
Discussion Starter · #14 ·
I put my clutch back to stock and left the light pipe on and it still goes up to 8600 or more could my speedo/tack be wrong or does that pipe make it over rev
 

·
Premium Member
Joined
·
1,711 Posts
I can just tell you what mine did with the D&D lite pipe and the D&D clutch kit for the pipe, max rpm I would get was 7850, this was back in december 2003.
 
1 - 15 of 15 Posts
Top