Arctic Chat : Arctic Cat Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just checked my belt after a 400 mile trip (alwayse seem to have to adjust the belt deflection on the diamond drive models) and noticed there are pieces missing from both the primary and the secondary clutches and the belt is worn down quite a bit. Wonrering if anyone else has had a simular problem?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Too stupid to post pics , sorry. There are chunks missing fron the shieves of both the clutches and the belt is worn so it can almost be removed without pushing the secondary apart. The only thing that I noticed was a bit of belt squeel once the belt was hot on the last half day of riding. Washed out the bellypan and off to the dealer for warranty I guess.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Just got the sled back from the dealer, they said they found a bolt floating around in the bellypan,I never saw it when I was looking at the clutches but they said it was under the primary.They think it was dropped into the bellypan when the sled was being built. Just wanted everyone to know that there is no big clutch problem to worry about. Happy trails.
 

·
Registered
Joined
·
104 Posts
I had a similar problem... except I was the dumb-ass leaving something in there.
Working on the sled, an EB, figuring where to put a sparkplug holder.
Got a call to head out riding... forgot that friggin plastic holder on the clutch cover. It didn't take long for the plastic and a little internal spring to get demolished.
Fortunately most damage was scrubbed out and now looks like some old war wounds in there.
 
1 - 6 of 6 Posts
Top