Arctic Cat Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,
I am posting for my grandfather as he has a 2015 arctic cat 400 altera that won’t start. He bought the machine two years ago and has barley used it as it only has a little under 800kms on it. When he last parked it he put the battery maintainer on it with the ignition key on by accident leaving the screen on. Today he went to start it discovering that he left the ignition on. When he got on it the speedometer screen was blank with only the backlight on and when pushing the start button it cranks but would not fire. He said the headlights turned on and was going to check the fuses and spark but could not find the fuses or spark plug, he says the fenders need to be removed but I don’t think they would make it that hard to get to. He was considering taking it to the stealership but I said it’s worth trying to fix it here as it’s probably something simple. Any ideas on what it could be or where the spark plug and fuses are?
 

·
Registered
Joined
·
9,034 Posts
I'm not sure what leaving the key on would do other than kill the battery even with maintainer on it. How long was it left on? More than likely battery is toast and you could load test it but you will need to charge it first.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I'm not sure what leaving the key on would do other than kill the battery even with maintainer on it. How long was it left on? More than likely battery is toast and you could load test it but you will need to charge it first.
Pretty sure it was left like that for a month and a half or so. I’m going to take the battery out of my atv and put it into his to see if that fixes it but I don’t think it will.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Pulled the front fender, gas tank and checked the fuses, then checked for spark and had that aswell. For some reason the speedometer started to work again. We tried to start it and it wouldn’t start, the we banged on top of the carb and tried to start it and bang! It started. Think the carb choke is sticking or the stupid electronic choke is staying on. Any ideas what could be wrong with the carb?
 

·
Registered
Joined
·
9,034 Posts
Maybe a good carb cleaning is in order. A company called Choke solutions may have a fix for the electric choke.
 

·
Administrator
Joined
·
7,599 Posts
Top off the tank with non ethanol gas and add seafoam. Then put some hours on it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Got it fixed, once It was running I Put fresh fuel in it and added sea foam to it. Pretty sure it was a mix of old fuel and the crap electronic choke. Thanks for everyone’s help!
 

·
Registered
Joined
·
9,034 Posts
Good to hear
 
1 - 8 of 8 Posts
Top