Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
i have a 06 v2 with an hmf pipe and a dynatek..when i first start it when its cold after i take the choke off it makes a loud popping noise while its idling..anyone else have this..it seems really lean i have my air screws at 3. 5 turns out..any jetting info???i have the jets in that hmf recommends..will a dial a jet help or a jet kit???
 

·
Registered
Joined
·
5,284 Posts
i have a similar setup but with a dynojet jet kit and have no problems, had the dynatek now copperhead. not sure about the poping noise your getting though. i run mine with the choke until it starts to spit and sputter then i back the choke off with my thumb on the throttle to keep it just above a idle and keep it there about 15 seconds after the choke is backed off fully. seems to work good for me like that.
 

·
Premium Member
Joined
·
15,413 Posts
'Popping' indicates a lean condition.

You can do what Kevin does... Using the choke until the engine sputters from too much fuel.

Or... Keep the choke partially on until the engine is warmed up a bit. For mine, I use full choke for the initial start, but once its running it only needs the choke lever approximatley in the halfway position.

A cold engine needs a richer fuel/air mix to start & run, the choke adds fuel to compensate.

When the engine is warmed up and the carb(s) is jetted correctly, there will be no popping noise without the choke.
 
1 - 3 of 3 Posts
Top