Arctic Chat : Arctic Cat Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
have a stock ZL800 01.Wondering what clutch adjustments i have in the clutch?problem that im having is at 3800-4000 clutch engages really hard like a neutral drop in a car.Would it be that i need a clutch kit,or an adjustment?bought sled brand new and even did it then.another question is where would i adjust the oil pump if i was running rich
 

·
Registered
Joined
·
75 Posts
My ZL 600 does the same thing on starting out, kind of grabs a bit. Gotta get the air compresser up to the lake and blow all the belt fuzz out of the clutch, seems to work, or take it out and give it a cleaning. Weights are probably hanging up on the fuzz. IF your 800 is like the wifes 700, take the belt off, you should then be able to see the oil pump under the carbs, the cable should have abit of slack, if not loosen the jam nuts, top one first then the bottom one. Make it so the flipper can move a bit before the cable starts to open the pump. Then use a mirror to check that the two lines line up at WOT. Just did this last weekend, thought I'd have to pull the carbs, got lucky, was very easy. :tongue_nana: Cat Dancin' Cat Dancin'
 

·
Registered
Joined
·
31 Posts
My clutch acted the same way last year. I pulled it apart last week and found that the bushings in the wieghts had worn away and the pins and weights were wearing grooves into eachother. I put in new weights, bushings and pins and it engages buttery smooth now. I'd say pull the primary off and give it a good inspection.
 
1 - 4 of 4 Posts
Top