Arctic Chat : Arctic Cat Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
i have a 2007 650 h1 and all of a sudden it seems like i have to give it a lot a gas to make the bike move and wont even hardly move itself in reverse i have a stage 3 airdam clutch in it and a clocked secondary i looked at everything and the belt looks ok but alot of belt dust in the housing anyone got any thoughts of what might be the problem ?
 

·
Administrator
Joined
·
40,662 Posts
Has to be an issue with the wet clutch. Does it rev up? Like it is slipping?
 

·
Administrator
Joined
·
40,662 Posts
Check your belt width to see if it is in spec.
 

·
Administrator
Joined
·
40,662 Posts
It eliminates the wet clutch look on the air dam site
 

·
Registered
Joined
·
704 Posts
Have you recently milked the oil or changed the oil? Not using wet clutch safe oil will kill your wet clutch fast.. If a belt doesent fix it your wet clutch is shot.

Isn't too hard to change but it's annoying. I've killed a couple and the bike acts exactly like you're describing.


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
40,662 Posts
Good to see you !!!!
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #10 ·
clutch prob

Have you recently milked the oil or changed the oil? Not using wet clutch safe oil will kill your wet clutch fast.. If a belt doesent fix it your wet clutch is shot.

Isn't too hard to change but it's annoying. I've killed a couple and the bike acts exactly like you're describing.


Sent from my iPhone using Tapatalk
Yes i just changed the oil before this started happening I put staffers oil in it im not sure if that is good for the wet clutch or not im gonna change it back to arctic cat oil !
 

·
Registered
Joined
·
704 Posts
Yes i just changed the oil before this started happening I put staffers oil in it im not sure if that is good for the wet clutch or not im gonna change it back to arctic cat oil !

Going back to arctic cat oil will only fix the problem if you haven't already ruined the wet clutch. If it still slips you'll need to find a used clutch in good shape or pony up the $230 for upgrade wet clutch shoes from airdam. Costs a little more than a whole new wet clutch from AC but they're a lot tougher.

See this howto for how to change the shoes on the clutch there's also a link to the clutch side dis assembly there.
http://www.arcticchat.com/forum/pin...install-upgraded-wet-clutch-shoes-airdam.html
 
1 - 11 of 11 Posts
Top