Arctic Chat : Arctic Cat Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
1,212 Posts
I've recently posted a similar problem, I think it's about 14-15 pages back. There's too much information for the speed that I can type :lol: , but you should look it up. " constant chaincase leak", last post around jan. 25. I did find that I had the best results filling to the add line (10 oz instead of 12) and so far I haven't had any more leakage, but it's only been 700 miles. :chug:
 

· Registered
Joined
·
1,212 Posts
The vent is at the top of the case, a small hole, maybe around 3/16". I'm still not sure mine is fixed, but it's not leaking yet. If it stays at the add line, which is about 10oz., I leave it there. I thought the problem was with heat build up, the muffler on a 800 sits about 1/2" away from the case, but I know the 500/600s are further away. As I've said on the other posts, I've tried everything I can think of, and if it leaks again, I'll try something else. I may be going on another 700 mile trip next weekend. that will be 1400 miles since my last repair attempt, and it's never gone that long without leaking, so I'll post the results :beer_cheers:
 

· Registered
Joined
·
1,212 Posts
you guys are lucky, I bet that in the 11,000 miles on my sled, I've pulled the cover off about 12 times :boohoo:
although the rest of the sled has been bulletproof.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top