Arctic Chat : Arctic Cat Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I have a 09 CFR 1000 that is stock other than a Y pipe and Speedwerx clutch kit with adjustable weights. The sled rips early on in the ride but then it begins to get inconsistent. Sometimes it will respond and rip like crazy, but other times it will feel flat and be doggy when you lay into the throttle or cruise at half to 3/4 throttle. Also, When letting of coming into a corner I can feel heat against my left boot periodically. clutches appear to be running hot but my alignment is perfect, belt deflection is correct and it does NOT have any issues with eating belts, I've been on the same belt for 500 miles. It didn't seem to do this stock it was just consistently strong all the time. Starting to wonder about this clutch kit.. Any help or advice out there would be much appreiciated. Finally have snow down in Southern, MN now so I can test some different things out without driving 4 hrs north.
 

·
Registered
Joined
·
242 Posts
Are sleds are known to run hot clutches so I put the mod rod vents in mine
 

Attachments

·
Registered
Joined
·
59 Posts
Discussion Starter #4
Yeah I thought about the vents but the other 09 1000R I had last year had zero issues with inconsistent performance etc nor did this sled before the speedwerx clutch kit went in.

When I had the secondary apart the sheaves looked good and bushing seemed fine but I'm not exactly sure how easy the sheaves are supposed to move in and out but it seemed ok. Sled only has 1500 miles on it but do those bushings go to heck pretty fast or what? Or are you supposed to replace it whenever you take the secondary apart?
 
1 - 4 of 4 Posts
Top